diff mbox series

[meta-python,1/3] python3-flask-restx: Add Flask-RestX Python Recipe

Message ID 20231031173554.1786139-2-arthur.oliveira@ossystems.com.br
State Under Review
Headers show
Series Branch Name: topic-add-python-recipes | expand

Commit Message

arthur.oliveira@ossystems.com.br Oct. 31, 2023, 5:35 p.m. UTC
From: Arthur Oliveira <arthur.oliveira@ossystems.com.br>

This commit introduces the python3-flask-restx recipe, which brings a fully
featured framework for fast, easy, and documented API development with Flask.
It is released under the BSD-3 license.

Signed-off-by: Arthur Oliveira <arthur.oliveira@ossystems.com.br>
---
 .../python/python3-flask-restx_1.2.0.bb             | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb

Comments

Tim Orling Nov. 1, 2023, 2:38 a.m. UTC | #1
On Tue, Oct 31, 2023 at 10:36 AM <arthur.oliveira@ossystems.com.br> wrote:

> From: Arthur Oliveira <arthur.oliveira@ossystems.com.br>
>
> This commit introduces the python3-flask-restx recipe, which brings a fully
> featured framework for fast, easy, and documented API development with
> Flask.
> It is released under the BSD-3 license.
>
> Signed-off-by: Arthur Oliveira <arthur.oliveira@ossystems.com.br>
> ---
>  .../python/python3-flask-restx_1.2.0.bb             | 13 +++++++++++++
>  1 file changed, 13 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/
> python3-flask-restx_1.2.0.bb
>
> diff --git a/meta-python/recipes-devtools/python/
> python3-flask-restx_1.2.0.bb b/meta-python/recipes-devtools/python/
> python3-flask-restx_1.2.0.bb
> new file mode 100644
> index 000000000..6b15e2535
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb
> @@ -0,0 +1,13 @@
> +DESCRIPTION = "Fully featured framework for fast, easy and documented API
> development with Flask"
> +LICENSE = "BSD-3"

this is not a valid SPDX license.
You probably mean “BSD-3-Clause”
https://spdx.org/licenses/BSD-3-Clause.html

But you are responsible for verification.


> +LIC_FILES_CHKSUM = "file://LICENSE;md5=c96dd911c6d9e32868b6bc667a38a3e2"
> +
> +SRC_URI[sha256sum] =
> "9a5338b108c57fbed1d24d5d53fe98442b2be7ffa2ff3291305af7a613ce6fc0"
> +
> +inherit pypi setuptools3
> +
> +RDEPENDS:${PN} += " \
> +    python3-isodate \
> +    python3-jsonschema \
> +    python3-pytz \
> +"
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105804):
> https://lists.openembedded.org/g/openembedded-devel/message/105804
> Mute This Topic: https://lists.openembedded.org/mt/102302623/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb b/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb
new file mode 100644
index 000000000..6b15e2535
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb
@@ -0,0 +1,13 @@ 
+DESCRIPTION = "Fully featured framework for fast, easy and documented API development with Flask"
+LICENSE = "BSD-3"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c96dd911c6d9e32868b6bc667a38a3e2"
+
+SRC_URI[sha256sum] = "9a5338b108c57fbed1d24d5d53fe98442b2be7ffa2ff3291305af7a613ce6fc0"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    python3-isodate \
+    python3-jsonschema \
+    python3-pytz \
+"