Patchwork [0/2] package_rpm and createrepo fixes

login
register
mail settings
Submitter Robert Yang
Date July 20, 2012, 9:49 a.m.
Message ID <cover.1342772908.git.liezhi.yang@windriver.com>
Download mbox
Permalink /patch/32705/
State New
Headers show

Pull-request

git://git.pokylinux.org/poky-contrib robert/createrepo

Comments

Robert Yang - July 20, 2012, 9:49 a.m.
Hi Saul,

For the error:

dbconfig.c:493: db3New: Assertion `dbOpts != ((void *)0) && *dbOpts != '\0'' failed.

The dbOpts is the value of _dbi_config_ or _dbi_config which are defined
in tmp/sysroots/i686-linux/usr/lib/rpm/macros, I can't reproduce it in
a normal build (on Ubuntu 10.10, Fedora 17 64bit, Ubuntu 12.04 64bit),
the error would happen when manually remove i686-linux/usr/lib/rpm/macros,
(but it should be there since the librpmdb-5.4.so is ready in a normal
build).

These two patches are used for fixing other issues of createrepo.

// Robert

The following changes since commit 64f7feb5c37d06e1985c59106cf2f7cd286fd0b8:

  EFI: Make installer EFI aware (2012-07-19 17:49:48 +0100)

are available in the git repository at:
  git://git.pokylinux.org/poky-contrib robert/createrepo
  http://git.pokylinux.org/cgit.cgi/poky-contrib/log/?h=robert/createrepo

Robert Yang (2):
  package_rpm: DEPLOY_DIR_RPM must exist before make index
  createrepo 0.4.11: fix the RDEPENDS

 meta/classes/package_rpm.bbclass                   |    4 ++--
 .../createrepo/createrepo_0.4.11.bb                |    4 +++-
 2 files changed, 5 insertions(+), 3 deletions(-)
Saul Wold - July 21, 2012, 12:19 a.m.
On 07/20/2012 02:49 AM, Robert Yang wrote:
> Hi Saul,
>
> For the error:
>
> dbconfig.c:493: db3New: Assertion `dbOpts != ((void *)0) && *dbOpts != '\0'' failed.
>
> The dbOpts is the value of _dbi_config_ or _dbi_config which are defined
> in tmp/sysroots/i686-linux/usr/lib/rpm/macros, I can't reproduce it in
> a normal build (on Ubuntu 10.10, Fedora 17 64bit, Ubuntu 12.04 64bit),
> the error would happen when manually remove i686-linux/usr/lib/rpm/macros,
> (but it should be there since the librpmdb-5.4.so is ready in a normal
> build).
>
> These two patches are used for fixing other issues of createrepo.
>
Turns out the real problem is that one machine was running Suse and the 
other Fedora and mixing the binaries via nfs and sstate was causing the 
real problem.

I made a note about the DEPENDS for createrepo, really should be part of 
package_rpm.bbclass

> // Robert
>
> The following changes since commit 64f7feb5c37d06e1985c59106cf2f7cd286fd0b8:
>
>    EFI: Make installer EFI aware (2012-07-19 17:49:48 +0100)
>
> are available in the git repository at:
>    git://git.pokylinux.org/poky-contrib robert/createrepo
>    http://git.pokylinux.org/cgit.cgi/poky-contrib/log/?h=robert/createrepo
>
> Robert Yang (2):
>    package_rpm: DEPLOY_DIR_RPM must exist before make index
>    createrepo 0.4.11: fix the RDEPENDS
>
>   meta/classes/package_rpm.bbclass                   |    4 ++--
>   .../createrepo/createrepo_0.4.11.bb                |    4 +++-
>   2 files changed, 5 insertions(+), 3 deletions(-)
>
>
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core
>
>
Merged into OE-Core

Thanks
	Sau!