diff mbox series

[meta-webserver] netdata: Upgrade 1.36.1 -> 1.43.0

Message ID 20231019080254.2009-1-sam.van.den.berge@gmail.com
State Under Review
Headers show
Series [meta-webserver] netdata: Upgrade 1.36.1 -> 1.43.0 | expand

Commit Message

Sam Van Den Berge Oct. 19, 2023, 8:02 a.m. UTC
From: Sam Van Den Berge <sam.van.den.berge@gmail.com>

libyaml dependency now required. See:
6ee42875c: Bundle libyaml

json-c also seems required now. If I don't enable it, I get compile errors.

compression and https options got renamed upstream to lz4 and openssl. See:
c74bf56ee: Code reorg and cleanup - enrichment of /api/v2

Signed-off-by: Sam Van Den Berge <sam.van.den.berge@gmail.com>
---
 .../netdata/{netdata_1.36.1.bb => netdata_1.43.0.bb} | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)
 rename meta-webserver/recipes-webadmin/netdata/{netdata_1.36.1.bb => netdata_1.43.0.bb} (88%)
diff mbox series

Patch

diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.36.1.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.43.0.bb
similarity index 88%
rename from meta-webserver/recipes-webadmin/netdata/netdata_1.36.1.bb
rename to meta-webserver/recipes-webadmin/netdata/netdata_1.43.0.bb
index 52d99e770..07ee03d86 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.36.1.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.43.0.bb
@@ -5,11 +5,11 @@  HOMEPAGE = "https://github.com/netdata/netdata/"
 LICENSE = "GPL-3.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
 
-DEPENDS += "libuv util-linux zlib"
+DEPENDS += "libuv util-linux zlib libyaml json-c"
 
 SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz \
 "
-SRC_URI[sha256sum] = "f4a1233112b55e07e2862ffda0416255f0aa4c8e2b16929b76fa7ad6b69fd931"
+SRC_URI[sha256sum] = "d3c66273d8eb62290d412c870dcde45ea214ad187df9d5350f682d9e6d19d426"
 
 # default netdata.conf for netdata configuration
 SRC_URI += "file://netdata.conf"
@@ -41,10 +41,10 @@  SYSTEMD_AUTO_ENABLE:${PN} = "enable"
 USERADD_PACKAGES = "${PN}"
 USERADD_PARAM:${PN} = "--system --no-create-home --home-dir ${localstatedir}/run/netdata --user-group netdata"
 
-PACKAGECONFIG ??= "https"
-PACKAGECONFIG[cloud] = "--enable-cloud, --disable-cloud, json-c"
-PACKAGECONFIG[compression] = "--enable-compression, --disable-compression, lz4"
-PACKAGECONFIG[https] = "--enable-https, --disable-https, openssl"
+PACKAGECONFIG ??= "openssl"
+PACKAGECONFIG[cloud] = "--enable-cloud, --disable-cloud,"
+PACKAGECONFIG[lz4] = "--enable-lz4, --disable-lz4, lz4"
+PACKAGECONFIG[openssl] = "--enable-openssl, --disable-openssl, openssl"
 
 # ebpf doesn't compile (or detect) the cross compilation well
 EXTRA_OECONF += "--disable-ebpf"