diff mbox series

[meta-java,master] meta-java: Adapt LICENSE as SPDX identifiers

Message ID 20231018104335.478441-1-akash.hadke27@gmail.com
State New
Headers show
Series [meta-java,master] meta-java: Adapt LICENSE as SPDX identifiers | expand

Commit Message

akash hadke Oct. 18, 2023, 10:43 a.m. UTC
As per Yocto 4.0 migration, LICENSE variables should use SPDX
identifiers
Convert this by a tool present at below location
poky/scripts/contrib/convert-spdx-licenses.py

Link: https://docs.yoctoproject.org/migration-guides/migration-4.0.html#license-changes

Signed-off-by: Ranjitsinh Rathod <ranjitsinh.rathod@kpit.com>
Signed-off-by: akash hadke <akash.hadke@kpit.com>
---
 .../ca-certificates-java/ca-certificates-java_20180516.bb       | 2 +-
 recipes-core/cacao/cacao-initial-native_0.98.bb                 | 2 +-
 recipes-core/cacao/cacao_git.bb                                 | 2 +-
 recipes-core/classpath/classpath-native.inc                     | 2 +-
 recipes-core/classpath/classpath.inc                            | 2 +-
 recipes-core/fastjar/fastjar.inc                                | 2 +-
 recipes-core/jamvm/jamvm.inc                                    | 2 +-
 recipes-core/xml-commons/xom_1.2.10.bb                          | 2 +-
 recipes-extended/dbus/dbus-java_2.7.bb                          | 2 +-
 9 files changed, 9 insertions(+), 9 deletions(-)

Comments

Jermain Horsman Oct. 19, 2023, 9:34 a.m. UTC | #1
On Wed, Oct 18, 2023 at 12:44 PM, akash hadke wrote:

> diff --git a/recipes-core/cacao/cacao_git.bb b/recipes-core/cacao/cacao_git.bb
> index fef7f34..80129b1 100644
> --- a/recipes-core/cacao/cacao_git.bb
> +++ b/recipes-core/cacao/cacao_git.bb
> @@ -1,6 +1,6 @@
>  SUMMARY = "CacaoVM for use as OpenEmbedded's Java VM"
>  HOMEPAGE = "http://www.cacaojvm.org/"
> -LICENSE  = "GPL-2.0"
> +LICENSE  = "GPL-2.0-only"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
>  SECTION  = "interpreters"
>  

You might want to double check the source, 
a quick look at e.g. https://bitbucket.org/cacaovm/cacao/src/master/COPYING:

    This program is free software; you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation; either version 2 of the License, or
    (at your option) any later version.

shows this should be 'GPL-2.0-or-later' instead.
akash hadke Oct. 19, 2023, 1:51 p.m. UTC | #2
On Thu, Oct 19, 2023 at 03:04 PM, Jermain Horsman wrote:

> 
> On Wed, Oct 18, 2023 at 12:44 PM, akash hadke wrote:
> 
> 
>> diff --git a/recipes-core/cacao/cacao_git.bb
>> b/recipes-core/cacao/cacao_git.bb
>> index fef7f34..80129b1 100644
>> --- a/recipes-core/cacao/cacao_git.bb
>> +++ b/recipes-core/cacao/cacao_git.bb
>> @@ -1,6 +1,6 @@
>> SUMMARY = "CacaoVM for use as OpenEmbedded's Java VM"
>> HOMEPAGE = " http://www.cacaojvm.org/"
>> -LICENSE = "GPL-2.0"
>> +LICENSE = "GPL-2.0-only"
>> LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
>> SECTION = "interpreters"
> 
> You might want to double check the source,
> a quick look at e.g. https://bitbucket.org/cacaovm/cacao/src/master/COPYING
> :
> 
> This program is free software; you can redistribute it and/or modify
> it under the terms of the GNU General Public License as published by
> the Free Software Foundation; either version 2 of the License, or
> (at your option) any later version.
> 
> shows this should be 'GPL-2.0-or-later' instead.

I only executed poky/scripts/contrib/convert-spdx-licenses.py script to update the LICENSEs as per kirkstone.
I did not check the source.
If you want I can share a separate patch to update LICENSE for this specific component.
akash hadke Oct. 26, 2023, 2:08 p.m. UTC | #3
Sent a v2 patch
https://lists.openembedded.org/g/openembedded-devel/message/105751
diff mbox series

Patch

diff --git a/recipes-core/ca-certificates-java/ca-certificates-java_20180516.bb b/recipes-core/ca-certificates-java/ca-certificates-java_20180516.bb
index 460d39a..368458b 100644
--- a/recipes-core/ca-certificates-java/ca-certificates-java_20180516.bb
+++ b/recipes-core/ca-certificates-java/ca-certificates-java_20180516.bb
@@ -1,7 +1,7 @@ 
 SUMMARY = "Common CA certificates (JKS trustStore)"
 DESCRIPTION = "This package uses the hooks of the ca-certificates \
 package to update the cacerts JKS trustStore used for many java runtimes."
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "\
 	file://debian/copyright;md5=ab0f6b6900f6564dc3e273dfa36fcc72 \
 	file://src/main/java/org/debian/security/InvalidKeystorePasswordException.java;endline=17;md5=f9150bf1ca3139a38ddb54f9e1c0eb9b \
diff --git a/recipes-core/cacao/cacao-initial-native_0.98.bb b/recipes-core/cacao/cacao-initial-native_0.98.bb
index 8432456..e8c9bdb 100644
--- a/recipes-core/cacao/cacao-initial-native_0.98.bb
+++ b/recipes-core/cacao/cacao-initial-native_0.98.bb
@@ -1,6 +1,6 @@ 
 SUMMARY = "CacaoVM for use as OpenEmbedded's Java VM"
 HOMEPAGE = "http://www.cacaojvm.org/"
-LICENSE  = "GPL-2.0"
+LICENSE  = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
 SECTION  = "interpreters"
 
diff --git a/recipes-core/cacao/cacao_git.bb b/recipes-core/cacao/cacao_git.bb
index fef7f34..80129b1 100644
--- a/recipes-core/cacao/cacao_git.bb
+++ b/recipes-core/cacao/cacao_git.bb
@@ -1,6 +1,6 @@ 
 SUMMARY = "CacaoVM for use as OpenEmbedded's Java VM"
 HOMEPAGE = "http://www.cacaojvm.org/"
-LICENSE  = "GPL-2.0"
+LICENSE  = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
 SECTION  = "interpreters"
 
diff --git a/recipes-core/classpath/classpath-native.inc b/recipes-core/classpath/classpath-native.inc
index c81e064..e325d94 100644
--- a/recipes-core/classpath/classpath-native.inc
+++ b/recipes-core/classpath/classpath-native.inc
@@ -1,6 +1,6 @@ 
 SUMMARY = "GNU Classpath standard Java libraries - For native Java-dependent programs"
 HOMEPAGE = "http://www.gnu.org/software/classpath/"
-LICENSE = "GPL-2.0 & SAX-PD"
+LICENSE = "GPL-2.0-only & SAX-PD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
 
 DEPENDS = "fastjar-native zip-native"
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index 35e7db3..0a53e14 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -3,7 +3,7 @@  HOMEPAGE = "http://www.gnu.org/software/classpath/"
 SECTION = "libs"
 
 # GPLv2 + custom linking exception
-LICENSE = "GPL-2.0 & SAX-PD"
+LICENSE = "GPL-2.0-only & SAX-PD"
 
 PBN = "classpath"
 
diff --git a/recipes-core/fastjar/fastjar.inc b/recipes-core/fastjar/fastjar.inc
index 8412236..1fb58a8 100644
--- a/recipes-core/fastjar/fastjar.inc
+++ b/recipes-core/fastjar/fastjar.inc
@@ -2,7 +2,7 @@  SUMMARY = "jar replacement written in C."
 HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
 SECTION = "devel"
 PRIORITY = "optional"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
 PR = "r1"
 
 DEPENDS = "zlib"
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index 693817f..57e77c1 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -1,6 +1,6 @@ 
 SUMMARY = "A compact Java Virtual Machine which conforms to the JVM specification version 2."
 HOMEPAGE = "http://jamvm.sourceforge.net/"
-LICENSE = "GPL-2.0"
+LICENSE = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
 
 DEPENDS = "zlib classpath virtual/javac-native libffi virtual/java-initial-native"
diff --git a/recipes-core/xml-commons/xom_1.2.10.bb b/recipes-core/xml-commons/xom_1.2.10.bb
index 42ad957..d01d5b2 100644
--- a/recipes-core/xml-commons/xom_1.2.10.bb
+++ b/recipes-core/xml-commons/xom_1.2.10.bb
@@ -1,7 +1,7 @@ 
 SUMMARY = "Tree-based API for processing XML with Java"
 DESCRIPTION = "XML object model which is a tree-based API for processing XML \
 with Java that strives for correctness, simplicity, and performance."
-LICENSE = "LGPL-2.1"
+LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f18f166096348ef9d457214a2484816"
 
 HOMEPAGE = "http://xom.nu"
diff --git a/recipes-extended/dbus/dbus-java_2.7.bb b/recipes-extended/dbus/dbus-java_2.7.bb
index 0e5ae92..1bfe5a7 100644
--- a/recipes-extended/dbus/dbus-java_2.7.bb
+++ b/recipes-extended/dbus/dbus-java_2.7.bb
@@ -4,7 +4,7 @@  SUMMARY:${PN}-bin = "${SUMMARY} (Binaries)"
 AUTHOR = "Matthew Johnson <dbus@matthew.ath.cx>"
 HOMEPAGE = "http://dbus.freedesktop.org/doc/dbus-java"
 SECTION = "libs"
-LICENSE = "LGPL-2.1 & AFL-2.1"
+LICENSE = "LGPL-2.1-only & AFL-2.1"
 
 DEPENDS = "libmatthew gettext-native fastjar-native"
 RDEPENDS:${PN}-viewer = "java2-runtime libunixsocket-java ${PN}-bin libmatthew-debug-java ${JPN}"