diff mbox series

[meta-oe] libbacktrace: Update version and enable shared library.

Message ID 20231017222454.26684-1-clopez@igalia.com
State Under Review
Headers show
Series [meta-oe] libbacktrace: Update version and enable shared library. | expand

Commit Message

Carlos Alberto Lopez Perez Oct. 17, 2023, 10:24 p.m. UTC
* Update to the last version as of today.
* Fix typo: EXTRA_OECONF
* Enable building a shared library (.so)
* Disable building a static library (.a)
* Manually passing `-fPIC` is not longer needed because that
  flag is already enabled by autotools when building the
  shared library.
* Enable the RISCV64 build-recause libunwind supports this
  archicture since OE-Core-rev: 2b2f6ff01efd

Signed-off-by: Carlos Alberto Lopez Perez <clopez@igalia.com>
---
 .../recipes-extended/libbacktrace/libbacktrace_git.bb    | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb b/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
index 609e55f4a..46fa81866 100644
--- a/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
+++ b/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
@@ -11,20 +11,17 @@  DEPENDS += "libunwind"
 SRC_URI = "git://github.com/ianlancetaylor/libbacktrace;protocol=https;branch=master"
 
 PV = "1.0+git${SRCPV}"
-SRCREV = "4f57c999716847e45505b3df170150876b545088"
+SRCREV = "9ae4f4ae4481b1e69d38ed810980d33103544613"
 
 S = "${WORKDIR}/git"
 
 inherit autotools
 
-EXTR_OECONF += "--with-system-libunwind"
-
-CFLAGS += "-fPIC"
+EXTRA_OECONF += "--with-system-libunwind --enable-shared --disable-static"
 
 do_configure() {
     oe_runconf
 }
 
-# libunwind does not support RISCV yet
-COMPATIBLE_HOST:riscv64 = "null"
+# libunwind does not support RISCV32 yet
 COMPATIBLE_HOST:riscv32 = "null"