diff mbox series

[meta-arago,master/kirkstone,2/2] packagegroups: base: Merge base-tisdk into base

Message ID 20231012174937.2047374-2-afd@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,master/kirkstone,1/2] packagegroups: base-tisdk: Remove iperf from packagegroup | expand

Commit Message

Andrew Davis Oct. 12, 2023, 5:49 p.m. UTC
Both contain packages for similar reasons, and every image using
one also includes the other. Merge these two packagegroups.

Signed-off-by: Andrew Davis <afd@ti.com>
---
 .../recipes-core/images/tisdk-base-image.bb   |  1 -
 .../images/tisdk-default-image.bb             |  1 -
 .../images/tisdk-thinlinux-image.bb           |  1 -
 .../packagegroup-arago-base-tisdk.bb          | 33 -------------------
 .../packagegroups/packagegroup-arago-base.bb  | 25 +++++++++++++-
 .../recipes-core/packagegroups/ti-world.bb    |  1 -
 6 files changed, 24 insertions(+), 38 deletions(-)
 delete mode 100644 meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base-tisdk.bb
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/tisdk-base-image.bb b/meta-arago-distro/recipes-core/images/tisdk-base-image.bb
index a70a0201..83f1899b 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-base-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-base-image.bb
@@ -12,7 +12,6 @@  ARAGO_BASE_IMAGE_EXTRA_INSTALL ?= ""
 IMAGE_INSTALL += "\
     packagegroup-arago-base \
     packagegroup-arago-console \
-    packagegroup-arago-base-tisdk \
     ${@oe.utils.conditional('ARAGO_BRAND', 'mainline', 'ti-test', '', d)} \
     ${ARAGO_BASE_IMAGE_EXTRA_INSTALL} \
 "
diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
index 787fac95..33ed0f57 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
@@ -15,7 +15,6 @@  SYSTEMD_DEFAULT_TARGET = " \
 IMAGE_INSTALL += "\
     packagegroup-arago-base \
     packagegroup-arago-console \
-    packagegroup-arago-base-tisdk \
     ti-test \
     ti-test-extras \
     ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-graphics','',d)} \
diff --git a/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb b/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
index a840b7a0..f266b14a 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
@@ -16,7 +16,6 @@  SYSTEMD_DEFAULT_TARGET = " \
 IMAGE_INSTALL += "\
     packagegroup-arago-base \
     packagegroup-arago-console \
-    packagegroup-arago-base-tisdk \
     ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-graphics','',d)} \
     packagegroup-arago-tisdk-connectivity \
     packagegroup-arago-tisdk-crypto \
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base-tisdk.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base-tisdk.bb
deleted file mode 100644
index 65fc015b..00000000
--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base-tisdk.bb
+++ /dev/null
@@ -1,33 +0,0 @@ 
-DESCRIPTION = "Additional packages beyond console packages shared by TI SDKs"
-LICENSE = "MIT"
-PR = "r24"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit packagegroup
-
-OPTEE_PKGS = " \
-    optee-os \
-    optee-client \
-    optee-test \
-    optee-examples \
-"
-
-RDEPENDS:${PN} = "\
-    dbus-broker \
-    expat \
-    glib-2.0 \
-    libxml2 \
-    libpcre \
-    iptables \
-    iperf3 \
-    netperf \
-    arago-gpl-notice \
-    arago-feed-config \
-    nfs-utils-client \
-    cifs-utils \
-    phytool \
-    ${@bb.utils.contains_any('OPTEEOUTPUTMACHINE', 'ti', "${OPTEE_PKGS}", "", d)} \
-"
-
-RDEPENDS:${PN}:append:k3 = " ${OPTEE_PKGS}"
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base.bb
index 1f63a7d0..d143f4f3 100644
--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base.bb
@@ -1,6 +1,6 @@ 
 SUMMARY = "Base tools that are recommended for most images"
 LICENSE = "MIT"
-PR = "r9"
+PR = "r10"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
@@ -36,6 +36,26 @@  ARAGO_EXTRA = "\
     kms++-python \
     can-utils \
     docker \
+    dbus-broker \
+    expat \
+    glib-2.0 \
+    libxml2 \
+    libpcre \
+    iptables \
+    iperf3 \
+    netperf \
+    arago-gpl-notice \
+    arago-feed-config \
+    nfs-utils-client \
+    cifs-utils \
+    phytool \
+"
+
+OPTEE_PKGS = " \
+    optee-os \
+    optee-client \
+    optee-test \
+    optee-examples \
 "
 
 # minimal set of packages - needed to boot
@@ -44,4 +64,7 @@  RDEPENDS:${PN} = "\
     ${@bb.utils.contains('MACHINE_FEATURES', 'alsa', '${ARAGO_ALSA_BASE}', '',d)} \
     ${ARAGO_BASE} \
     ${ARAGO_EXTRA} \
+    ${@bb.utils.contains_any('OPTEEOUTPUTMACHINE', 'ti', "${OPTEE_PKGS}", "", d)} \
 "
+
+RDEPENDS:${PN}:append:k3 = " ${OPTEE_PKGS}"
diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-world.bb b/meta-arago-distro/recipes-core/packagegroups/ti-world.bb
index 4a7a5e3f..50cf2552 100644
--- a/meta-arago-distro/recipes-core/packagegroups/ti-world.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/ti-world.bb
@@ -41,7 +41,6 @@  OPENCL = " \
 RDEPENDS:${PN} = "\
     packagegroup-arago-base \
     packagegroup-arago-console \
-    packagegroup-arago-base-tisdk \
     ti-test \
     ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-graphics','',d)} \
     ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-gtk','',d)} \