diff mbox series

[meta-python] python3-pylint: allow native build

Message ID 20231011190650.622937-1-daniel.mcgregor@vecima.com
State Under Review
Headers show
Series [meta-python] python3-pylint: allow native build | expand

Commit Message

Daniel McGregor Oct. 11, 2023, 7:06 p.m. UTC
We use pylint for some native recipes in our build. Allow pylint
to be a native recipe, and likewise allow its runtime dependencies
to be native recipes.

Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
---
 meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb  | 2 ++
 meta-python/recipes-devtools/python/python3-dill_0.3.7.bb     | 2 ++
 meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb   | 2 ++
 meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb   | 2 ++
 meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb | 2 ++
 5 files changed, 10 insertions(+)

Comments

Khem Raj Oct. 11, 2023, 7:33 p.m. UTC | #1
Thanks for heads up. Armin is planning another downmerge from master
which should cover this too

On Wed, Oct 11, 2023 at 12:07 PM Dan McGregor <danismostlikely@gmail.com> wrote:
>
> We use pylint for some native recipes in our build. Allow pylint
> to be a native recipe, and likewise allow its runtime dependencies
> to be native recipes.
>
> Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
> ---
>  meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb  | 2 ++
>  meta-python/recipes-devtools/python/python3-dill_0.3.7.bb     | 2 ++
>  meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb   | 2 ++
>  meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb   | 2 ++
>  meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb | 2 ++
>  5 files changed, 10 insertions(+)
>
> diff --git a/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb b/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
> index 2f80187b2b2..cdf6fc74edf 100644
> --- a/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
> +++ b/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
> @@ -34,3 +34,5 @@ RDEPENDS:${PN}-tests:class-target += "\
>      ${PYTHON_PN}-unittest \
>      ${PYTHON_PN}-xml \
>  "
> +
> +BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb b/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
> index b6b788110d9..673964f3b70 100644
> --- a/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
> +++ b/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
> @@ -15,3 +15,5 @@ RDEPENDS:${PN} += "\
>      ${PYTHON_PN}-profile \
>      ${PYTHON_PN}-core \
>  "
> +
> +BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb b/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
> index a2c72fcc997..265b28a7715 100644
> --- a/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
> +++ b/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
> @@ -9,3 +9,5 @@ SRC_URI[sha256sum] = "348e0240c33b60bbdf4e523192ef919f28cb2c3d7d5c7794f74009290f
>  inherit pypi setuptools3
>
>  DEPENDS += "${PYTHON_PN}-pytest-runner-native"
> +
> +BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> index 413e6599db1..bd2faa5b5af 100644
> --- a/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> +++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> @@ -48,3 +48,5 @@ do_install_ptest() {
>      install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
>      sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
>  }
> +
> +BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
> index e86a3c78981..59e83e00db7 100644
> --- a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
> +++ b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
> @@ -27,3 +27,5 @@ do_install_ptest() {
>          install -d ${D}${PTEST_PATH}/tests
>          cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
>  }
> +
> +BBCLASSEXTEND = "native nativesdk"
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105436): https://lists.openembedded.org/g/openembedded-devel/message/105436
> Mute This Topic: https://lists.openembedded.org/mt/101903777/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Daniel McGregor Oct. 11, 2023, 7:49 p.m. UTC | #2
Great. Though looking at the original message that I sent to the list
it's using the wrong author email address. It worked fine the other
day, so I wonder what I did differently. Should be the @vecima.com
address.

On Wed, 11 Oct 2023 at 13:33, Khem Raj <raj.khem@gmail.com> wrote:
>
> Thanks for heads up. Armin is planning another downmerge from master
> which should cover this too
>
> On Wed, Oct 11, 2023 at 12:07 PM Dan McGregor <danismostlikely@gmail.com> wrote:
> >
> > We use pylint for some native recipes in our build. Allow pylint
> > to be a native recipe, and likewise allow its runtime dependencies
> > to be native recipes.
> >
> > Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
> > ---
> >  meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb  | 2 ++
> >  meta-python/recipes-devtools/python/python3-dill_0.3.7.bb     | 2 ++
> >  meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb   | 2 ++
> >  meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb   | 2 ++
> >  meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb | 2 ++
> >  5 files changed, 10 insertions(+)
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb b/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
> > index 2f80187b2b2..cdf6fc74edf 100644
> > --- a/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
> > +++ b/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
> > @@ -34,3 +34,5 @@ RDEPENDS:${PN}-tests:class-target += "\
> >      ${PYTHON_PN}-unittest \
> >      ${PYTHON_PN}-xml \
> >  "
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> > diff --git a/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb b/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
> > index b6b788110d9..673964f3b70 100644
> > --- a/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
> > +++ b/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
> > @@ -15,3 +15,5 @@ RDEPENDS:${PN} += "\
> >      ${PYTHON_PN}-profile \
> >      ${PYTHON_PN}-core \
> >  "
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> > diff --git a/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb b/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
> > index a2c72fcc997..265b28a7715 100644
> > --- a/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
> > +++ b/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
> > @@ -9,3 +9,5 @@ SRC_URI[sha256sum] = "348e0240c33b60bbdf4e523192ef919f28cb2c3d7d5c7794f74009290f
> >  inherit pypi setuptools3
> >
> >  DEPENDS += "${PYTHON_PN}-pytest-runner-native"
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> > diff --git a/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > index 413e6599db1..bd2faa5b5af 100644
> > --- a/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > +++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > @@ -48,3 +48,5 @@ do_install_ptest() {
> >      install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
> >      sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
> >  }
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> > diff --git a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
> > index e86a3c78981..59e83e00db7 100644
> > --- a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
> > +++ b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
> > @@ -27,3 +27,5 @@ do_install_ptest() {
> >          install -d ${D}${PTEST_PATH}/tests
> >          cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
> >  }
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> > --
> > 2.41.0
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#105436): https://lists.openembedded.org/g/openembedded-devel/message/105436
> > Mute This Topic: https://lists.openembedded.org/mt/101903777/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb b/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
index 2f80187b2b2..cdf6fc74edf 100644
--- a/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-astroid_3.0.0.bb
@@ -34,3 +34,5 @@  RDEPENDS:${PN}-tests:class-target += "\
     ${PYTHON_PN}-unittest \
     ${PYTHON_PN}-xml \
 "
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb b/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
index b6b788110d9..673964f3b70 100644
--- a/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
+++ b/meta-python/recipes-devtools/python/python3-dill_0.3.7.bb
@@ -15,3 +15,5 @@  RDEPENDS:${PN} += "\
     ${PYTHON_PN}-profile \
     ${PYTHON_PN}-core \
 "
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb b/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
index a2c72fcc997..265b28a7715 100644
--- a/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-mccabe_0.7.0.bb
@@ -9,3 +9,5 @@  SRC_URI[sha256sum] = "348e0240c33b60bbdf4e523192ef919f28cb2c3d7d5c7794f74009290f
 inherit pypi setuptools3
 
 DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
index 413e6599db1..bd2faa5b5af 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
@@ -48,3 +48,5 @@  do_install_ptest() {
     install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
     sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
 }
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
index e86a3c78981..59e83e00db7 100644
--- a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
+++ b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.1.bb
@@ -27,3 +27,5 @@  do_install_ptest() {
         install -d ${D}${PTEST_PATH}/tests
         cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
 }
+
+BBCLASSEXTEND = "native nativesdk"