ffa-debugfs-mod: Do not build for rpi machines

Message ID 20220202055225.2212857-1-raj.khem@gmail.com
State New
Headers show
Series ffa-debugfs-mod: Do not build for rpi machines | expand

Commit Message

Khem Raj Feb. 2, 2022, 5:52 a.m. UTC
The module can not be compiled without patching kernel
and rpi machines use linux-raspberrypi and are either arm32
or arm64 machines, so this module tries to build in world envs

This helps meta-arm to live in multi-BSP envs

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Ross Burton Feb. 2, 2022, 10:03 a.m. UTC | #1
If this needs kernel patches then the base recipe should set
COMPATIBLE_HOST to invalid and then machines opt-in by enabling it
with bbappends in meta-arm-bsp.

Ross

On Wed, 2 Feb 2022 at 05:52, Khem Raj <raj.khem@gmail.com> wrote:
>
> The module can not be compiled without patching kernel
> and rpi machines use linux-raspberrypi and are either arm32
> or arm64 machines, so this module tries to build in world envs
>
> This helps meta-arm to live in multi-BSP envs
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb b/meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb
> index 2db8afc..93f5f02 100644
> --- a/meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb
> +++ b/meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb
> @@ -29,3 +29,4 @@ do_install:append() {
>  }
>
>  COMPATIBLE_HOST = "(arm|aarch64).*-linux"
> +COMPATIBLE_HOST:rpi = "null"
> --
> 2.35.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#2935): https://lists.yoctoproject.org/g/meta-arm/message/2935
> Mute This Topic: https://lists.yoctoproject.org/mt/88852674/1676615
> Group Owner: meta-arm+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-arm/unsub [ross@burtonini.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Ross Burton Feb. 8, 2022, 12:30 p.m. UTC | #2
On Wed, 2 Feb 2022 at 05:52, Khem Raj <raj.khem@gmail.com> wrote:
>
> The module can not be compiled without patching kernel
> and rpi machines use linux-raspberrypi and are either arm32
> or arm64 machines, so this module tries to build in world envs
>
> This helps meta-arm to live in multi-BSP envs

What failure did you get when building for RPi? I can't make it break
by building it for non-corstone machines.

Ross
Khem Raj Feb. 8, 2022, 3:20 p.m. UTC | #3
On Tue, Feb 8, 2022 at 4:30 AM Ross Burton <ross@burtonini.com> wrote:

> On Wed, 2 Feb 2022 at 05:52, Khem Raj <raj.khem@gmail.com> wrote:
> >
> > The module can not be compiled without patching kernel
> > and rpi machines use linux-raspberrypi and are either arm32
> > or arm64 machines, so this module tries to build in world envs
> >
> > This helps meta-arm to live in multi-BSP envs
>
> What failure did you get when building for RPi? I can't make it break
> by building it for non-corstone machines.
>

Build it for a BSP which does not use yocto reference kernel


> Ross
>
Ross Burton Feb. 8, 2022, 4:37 p.m. UTC | #4
On Tue, 8 Feb 2022 at 15:21, Khem Raj <raj.khem@gmail.com> wrote:
>> What failure did you get when building for RPi? I can't make it break
>> by building it for non-corstone machines.
>
> Build it for a BSP which does not use yocto reference kernel

Worked for our TC0 machine, which uses the Android Common Kernel.

What failure did you get when building for RPi?

Ross
Khem Raj Feb. 8, 2022, 4:55 p.m. UTC | #5
On Tue, Feb 8, 2022 at 8:37 AM Ross Burton <ross@burtonini.com> wrote:
>
> On Tue, 8 Feb 2022 at 15:21, Khem Raj <raj.khem@gmail.com> wrote:
> >> What failure did you get when building for RPi? I can't make it break
> >> by building it for non-corstone machines.
> >
> > Build it for a BSP which does not use yocto reference kernel
>
> Worked for our TC0 machine, which uses the Android Common Kernel.
>
> What failure did you get when building for RPi?

https://errors.yoctoproject.org/Errors/Details/623682/

>
> Ross
Khem Raj Feb. 8, 2022, 4:56 p.m. UTC | #6
On Tue, Feb 8, 2022 at 8:55 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Tue, Feb 8, 2022 at 8:37 AM Ross Burton <ross@burtonini.com> wrote:
> >
> > On Tue, 8 Feb 2022 at 15:21, Khem Raj <raj.khem@gmail.com> wrote:
> > >> What failure did you get when building for RPi? I can't make it break
> > >> by building it for non-corstone machines.
> > >
> > > Build it for a BSP which does not use yocto reference kernel
> >
> > Worked for our TC0 machine, which uses the Android Common Kernel.
> >
> > What failure did you get when building for RPi?
>
> https://errors.yoctoproject.org/Errors/Details/623682/

you are carrying
meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0018-arm_ffa-introducing-Arm-FF-A-low-level-driver.patch
which is not upstream I guess yet, RPI uses 5.10 kernel.

>
> >
> > Ross
Ross Burton Feb. 8, 2022, 5:39 p.m. UTC | #7
On Tue, 8 Feb 2022 at 16:57, Khem Raj <raj.khem@gmail.com> wrote:
> you are carrying
> meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0018-arm_ffa-introducing-Arm-FF-A-low-level-driver.patch
> which is not upstream I guess yet, RPI uses 5.10 kernel.

That's a U-Boot patch. :)

But I did notice that the target I tested, the TC0 machine with 5.10
ACK, is also patched with the FFA driver backport (which is 5.14
onwards).

Not sure calling out rpi specifically is the right thing here as this
isn't RPi specific, but I don't fancy listing every BSP which doesn't
have 5.14 either. Neither is making the recipe EXCLUDE_FROM_WORLD a
good solution.  Hmm.  I'll have a think.

Ross
Khem Raj Feb. 8, 2022, 6:12 p.m. UTC | #8
On Tue, Feb 8, 2022 at 9:39 AM Ross Burton <ross@burtonini.com> wrote:
>
> On Tue, 8 Feb 2022 at 16:57, Khem Raj <raj.khem@gmail.com> wrote:
> > you are carrying
> > meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0018-arm_ffa-introducing-Arm-FF-A-low-level-driver.patch
> > which is not upstream I guess yet, RPI uses 5.10 kernel.
>
> That's a U-Boot patch. :)
>
> But I did notice that the target I tested, the TC0 machine with 5.10
> ACK, is also patched with the FFA driver backport (which is 5.14
> onwards).
>
> Not sure calling out rpi specifically is the right thing here as this
> isn't RPi specific, but I don't fancy listing every BSP which doesn't
> have 5.14 either. Neither is making the recipe EXCLUDE_FROM_WORLD a
> good solution.  Hmm.  I'll have a think.

needs a kernel version check perhaps in some ways.

>
> Ross

Patch

diff --git a/meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb b/meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb
index 2db8afc..93f5f02 100644
--- a/meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb
+++ b/meta-arm/recipes-kernel/ffa-debugfs/ffa-debugfs-mod_2.1.0.bb
@@ -29,3 +29,4 @@  do_install:append() {
 }
 
 COMPATIBLE_HOST = "(arm|aarch64).*-linux"
+COMPATIBLE_HOST:rpi = "null"