Patchwork [bitbake-devel,0/1] bitbake: Abort build if runtime dependency conflict

login
register
mail settings
Submitter wenzong.fan@windriver.com
Date July 11, 2012, 3:28 a.m.
Message ID <cover.1341977062.git.wenzong.fan@windriver.com>
Download mbox
Permalink /patch/31737/
State New
Headers show

Pull-request

git://git.pokylinux.org/poky-contrib wenzong/2734

Comments

wenzong.fan@windriver.com - July 11, 2012, 3:28 a.m.
From: Wenzong Fan <wenzong.fan@windriver.com>

If found any runtime dependency conflict from PREFERRED_PROVIDER entries,
bitbake will print an ERROR and let the build go on.
 
This is a little confusion for a long time build, it should be abort
immediately while an ERROR occured.

The following changes since commit 5142a1e95ed7db7e09ef31f645d45bb7e380d1d6:

  subversion: do_install failed (parallel issue) (2012-07-10 20:35:11 +0100)

are available in the git repository at:
  git://git.pokylinux.org/poky-contrib wenzong/2734
  http://git.pokylinux.org/cgit.cgi/poky-contrib/log/?h=wenzong/2734

Wenzong Fan (1):
  bitbake: Abort build if runtime dependency conflict

 bitbake/lib/bb/providers.py |    2 ++
 bitbake/lib/bb/taskdata.py  |    3 ++-
 2 files changed, 4 insertions(+), 1 deletions(-)