diff mbox series

[meta-python] python3-flask-cors: add initial version of the recipe for 4.0.0

Message ID 20230929220009.2146196-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-flask-cors: add initial version of the recipe for 4.0.0 | expand

Commit Message

Derek Straka Sept. 29, 2023, 10 p.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../python/python3-flask-cors_4.0.0.bb           | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-flask-cors_4.0.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-flask-cors_4.0.0.bb b/meta-python/recipes-devtools/python/python3-flask-cors_4.0.0.bb
new file mode 100644
index 000000000..1d0d86b4e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-cors_4.0.0.bb
@@ -0,0 +1,16 @@ 
+HOMEPAGE = "https://pypi.python.org/pypi/Flask-Cors/"
+SUMMARY = "A Flask extension adding a decorator for CORS support"
+DESCRIPTION = "\
+  A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible \
+  "
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=118fecaa576ab51c1520f95e98db61ce"
+
+PYPI_PACKAGE = "Flask-Cors"
+
+SRC_URI[sha256sum] = "f268522fcb2f73e2ecdde1ef45e2fd5c71cc48fe03cffb4b441c6d1b40684eb0"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-flask"