diff mbox series

curl: Skip tests marked flaky

Message ID 20230928015606.3252024-1-robert.joslyn@redrectangle.org
State Accepted, archived
Commit 34f37de80928bb23a594268b0e996beb575ca51b
Headers show
Series curl: Skip tests marked flaky | expand

Commit Message

Robert Joslyn Sept. 28, 2023, 1:56 a.m. UTC
From: Robert Joslyn <robert.joslyn@redrectangle.org>

Some tests can fail intermittently and upstream has marked these as
flaky so they can easily be skipped. At present there are 12 tests
marked flaky with 10 of them running in the default recipe
configuration. Skip them to avoid the failures.

Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org>
---
 meta/recipes-support/curl/curl/run-ptest | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Alexander Kanavin Sept. 28, 2023, 12:42 p.m. UTC | #1
Thanks, I suspect many of those were enabled to begin with when I
recently changed the packaging to include all the tests.

Alex

On Thu, 28 Sept 2023 at 03:57, Robert Joslyn via
lists.openembedded.org
<robert.joslyn=redrectangle.org@lists.openembedded.org> wrote:
>
> From: Robert Joslyn <robert.joslyn@redrectangle.org>
>
> Some tests can fail intermittently and upstream has marked these as
> flaky so they can easily be skipped. At present there are 12 tests
> marked flaky with 10 of them running in the default recipe
> configuration. Skip them to avoid the failures.
>
> Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org>
> ---
>  meta/recipes-support/curl/curl/run-ptest | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
> index 95af2bd7b3..8f9c20f34d 100644
> --- a/meta/recipes-support/curl/curl/run-ptest
> +++ b/meta/recipes-support/curl/curl/run-ptest
> @@ -1,6 +1,6 @@
>  #!/bin/sh
>  cd tests
> -{ ./runtests.pl -a -n -s -j4 || echo "FAIL: curl" ; } | sed \
> +{ ./runtests.pl -a -n -s -j4 !flaky || echo "FAIL: curl" ; } | sed \
>       -e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
>       -e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
>       -e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188349): https://lists.openembedded.org/g/openembedded-core/message/188349
> Mute This Topic: https://lists.openembedded.org/mt/101630676/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 95af2bd7b3..8f9c20f34d 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,6 @@ 
 #!/bin/sh
 cd tests
-{ ./runtests.pl -a -n -s -j4 || echo "FAIL: curl" ; } | sed \
+{ ./runtests.pl -a -n -s -j4 !flaky || echo "FAIL: curl" ; } | sed \
      -e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
      -e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
      -e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'