diff mbox series

[meta-oe] webkitgtk3: reduce size of -dbg package

Message ID 20230925235005.2387359-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] webkitgtk3: reduce size of -dbg package | expand

Commit Message

Khem Raj Sept. 25, 2023, 11:50 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

Unless DEBUG_BUILD is enabled, pass -g1 to massively reduce the size of
the debug symbols

  Level 1 produces minimal information, enough for making backtraces in
  parts of the program that you don't plan to debug. This includes
  descriptions of functions and external variables, and line number
  tables, but no information about local variables.

This makes the sstate objects a lot more manageable, and packaging
faster.

Based on - https://patchwork.yoctoproject.org/project/oe-core/patch/20230925113508.1087898-1-ross.burton@arm.com/

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb b/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb
index 5f94d32ee4..8962dbfe7d 100644
--- a/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb
+++ b/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb
@@ -86,6 +86,9 @@  EXTRA_OECMAKE = " \
 		${@bb.utils.contains('GIDOCGEN_ENABLED', 'True', '-DENABLE_DOCUMENTATION=ON', '-DENABLE_DOCUMENTATION=OFF', d)} \
 		-DENABLE_MINIBROWSER=ON \
 		"
+# Unless DEBUG_BUILD is enabled, pass -g1 to massively reduce the size of the
+# debug symbols (4.3GB to 700M at time of writing)
+DEBUG_FLAGS:append = "${@oe.utils.vartrue('DEBUG_BUILD', '', ' -g1', d)}"
 
 # Javascript JIT is not supported on ARC
 EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "