diff mbox series

[meta-python] python3-autoflake: add recipe for v2.2.1

Message ID 20230921072243.311712-1-dev@g0hl1n.net
State Under Review
Headers show
Series [meta-python] python3-autoflake: add recipe for v2.2.1 | expand

Commit Message

Richard Leitner Sept. 21, 2023, 7:22 a.m. UTC
autoflake is a python library which removes unused imports and unused
variables from Python code. This recipe uses pypi as source:

	https://pypi.org/project/autoflake/

Signed-off-by: Richard Leitner <dev@g0hl1n.net>
---
 .../python/python3-autoflake_2.2.1.bb                | 12 ++++++++++++
 1 file changed, 12 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-autoflake_2.2.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-autoflake_2.2.1.bb b/meta-python/recipes-devtools/python/python3-autoflake_2.2.1.bb
new file mode 100644
index 000000000..7b7430866
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-autoflake_2.2.1.bb
@@ -0,0 +1,12 @@ 
+SUMMARY = "Removes unused imports and unused variables"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=88246be6a34c1496c253f58599f3db85"
+
+SRC_URI[sha256sum] = "62b7b6449a692c3c9b0c916919bbc21648da7281e8506bcf8d3f8280e431ebc1"
+
+inherit pypi python_hatchling
+
+RDEPENDS:${PN} += "python3-pyflakes"
+
+BBCLASSEXTEND = "native nativesdk"