Patchwork lsbinitiscripts: Add glib-2.0 to DEPENDS list

login
register
mail settings
Submitter Saul Wold
Date June 27, 2012, 4:48 p.m.
Message ID <1340815691-12117-1-git-send-email-sgw@linux.intel.com>
Download mbox | patch
Permalink /patch/30763/
State New
Headers show

Comments

Saul Wold - June 27, 2012, 4:48 p.m.
ppp-watch requires it.

x86_64-poky-linux-gcc    -m64 --sysroot=/intel/poky2/builds/fetch/tmp/sysroots/qemux86-64 -O2 -pipe -g -feliminate-unused-debug-types  -Wall -D_GNU_SOURCE `pkg-config glib-2.0 --cflags` -c ppp-watch.c -o ppp-watch.o
Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found
ppp-watch.c:78:18: fatal error: glib.h: No such file or directory
compilation terminated.
make[1]: *** [ppp-watch.o] Error 1
make[1]: Leaving directory `/intel/poky2/builds/fetch/tmp/work/x86_64-poky-linux/lsbinitscripts-9.03-r0/initscripts-9.03/src'

Signed-off-by: Saul Wold <sgw@linux.intel.com>
---
 meta/recipes-extended/lsb/lsbinitscripts_9.03.bb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Patch

diff --git a/meta/recipes-extended/lsb/lsbinitscripts_9.03.bb b/meta/recipes-extended/lsb/lsbinitscripts_9.03.bb
index dd92a92..ff11c53 100644
--- a/meta/recipes-extended/lsb/lsbinitscripts_9.03.bb
+++ b/meta/recipes-extended/lsb/lsbinitscripts_9.03.bb
@@ -1,7 +1,7 @@ 
 DESCRIPTION = "SysV init scripts which only is used in an LSB image"
 SECTION = "base"
 LICENSE = "GPLv2"
-DEPENDS = "popt"
+DEPENDS = "popt glib-2.0"
 PR = "r0"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=ebf4e8b49780ab187d51bd26aaa022c6"