[v4,meta-oe] rtc-tools: Add a recipe

Message ID 20220128195459.216370-1-festevam@gmail.com
State New
Headers show
Series [v4,meta-oe] rtc-tools: Add a recipe | expand

Commit Message

Fabio Estevam Jan. 28, 2022, 7:54 p.m. UTC
From: Fabio Estevam <festevam@denx.de>

rtc-tools is a useful utility developed by Alexandre Belloni
for testing RTC kernel drivers, such as y2038 support.

Based on the initial recipe from Heiko Schocher <hs@denx.de>.

Signed-off-by: Fabio Estevam <festevam@denx.de>
---
Changes since v3:
- Removed the TARGET_CC_ARCH line (Peter/Khem).

 .../0001-rtc-tools-Add-a-Makefile.patch       | 40 +++++++++++++++++++
 .../rtc-tools/rtc-tools_1.0.0.bb              | 16 ++++++++
 2 files changed, 56 insertions(+)
 create mode 100644 meta-oe/recipes-support/rtc-tools/rtc-tools/0001-rtc-tools-Add-a-Makefile.patch
 create mode 100644 meta-oe/recipes-support/rtc-tools/rtc-tools_1.0.0.bb

Comments

Otavio Salvador Jan. 28, 2022, 11:57 p.m. UTC | #1
Em sex., 28 de jan. de 2022 às 16:54, Fabio Estevam
<festevam@gmail.com> escreveu:
>
> From: Fabio Estevam <festevam@denx.de>
>
> rtc-tools is a useful utility developed by Alexandre Belloni
> for testing RTC kernel drivers, such as y2038 support.
>
> Based on the initial recipe from Heiko Schocher <hs@denx.de>.
>
> Signed-off-by: Fabio Estevam <festevam@denx.de>

Acked-by: Otavio Salvador <otavio@ossystems.com.br>
Fabio Estevam Feb. 7, 2022, 10:43 p.m. UTC | #2
Hi Khem and Peter,

On Fri, Jan 28, 2022 at 8:57 PM Otavio Salvador
<otavio.salvador@ossystems.com.br> wrote:
>
> Em sex., 28 de jan. de 2022 às 16:54, Fabio Estevam
> <festevam@gmail.com> escreveu:
> >
> > From: Fabio Estevam <festevam@denx.de>
> >
> > rtc-tools is a useful utility developed by Alexandre Belloni
> > for testing RTC kernel drivers, such as y2038 support.
> >
> > Based on the initial recipe from Heiko Schocher <hs@denx.de>.
> >
> > Signed-off-by: Fabio Estevam <festevam@denx.de>
>
> Acked-by: Otavio Salvador <otavio@ossystems.com.br>

Are you happy with this version?

Thanks
Khem Raj Feb. 7, 2022, 11:21 p.m. UTC | #3
On Mon, Feb 7, 2022 at 2:44 PM Fabio Estevam <festevam@gmail.com> wrote:

> Hi Khem and Peter,
>
> On Fri, Jan 28, 2022 at 8:57 PM Otavio Salvador
> <otavio.salvador@ossystems.com.br> wrote:
> >
> > Em sex., 28 de jan. de 2022 às 16:54, Fabio Estevam
> > <festevam@gmail.com> escreveu:
> > >
> > > From: Fabio Estevam <festevam@denx.de>
> > >
> > > rtc-tools is a useful utility developed by Alexandre Belloni
> > > for testing RTC kernel drivers, such as y2038 support.
> > >
> > > Based on the initial recipe from Heiko Schocher <hs@denx.de>.
> > >
> > > Signed-off-by: Fabio Estevam <festevam@denx.de>
> >
> > Acked-by: Otavio Salvador <otavio@ossystems.com.br>
>



> Are you happy with this version


Yes it should be in master


>
> Thanks
>
Fabio Estevam Feb. 7, 2022, 11:31 p.m. UTC | #4
Hi Khem,

On Mon, Feb 7, 2022 at 8:21 PM Khem Raj <raj.khem@gmail.com> wrote:

> Yes it should be in master

Sorry, I don't see it in master yet:
https://github.com/openembedded/meta-openembedded/tree/master/meta-oe/recipes-support
Fabio Estevam Feb. 10, 2022, 5:37 p.m. UTC | #5
On Mon, Feb 7, 2022 at 8:31 PM Fabio Estevam <festevam@gmail.com> wrote:
>
> Hi Khem,
>
> On Mon, Feb 7, 2022 at 8:21 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> > Yes it should be in master
>
> Sorry, I don't see it in master yet:
> https://github.com/openembedded/meta-openembedded/tree/master/meta-oe/recipes-support

I can see it in master now, thanks.

Patch

diff --git a/meta-oe/recipes-support/rtc-tools/rtc-tools/0001-rtc-tools-Add-a-Makefile.patch b/meta-oe/recipes-support/rtc-tools/rtc-tools/0001-rtc-tools-Add-a-Makefile.patch
new file mode 100644
index 000000000000..1f3b3b3b020e
--- /dev/null
+++ b/meta-oe/recipes-support/rtc-tools/rtc-tools/0001-rtc-tools-Add-a-Makefile.patch
@@ -0,0 +1,39 @@ 
+From 3e9dfc0f21191bdb3ab719479e9c1997a61c5044 Mon Sep 17 00:00:00 2001
+From: Fabio Estevam <festevam@denx.de>
+Date: Fri, 28 Jan 2022 13:34:45 -0300
+Subject: [PATCH] rtc-tools: Add a Makefile
+
+Add a Makefile to make installation and uninstallation
+process easier.
+
+Upstream-Status: Submitted [https://marc.info/?l=linux-rtc&m=164332426030004&w=2]
+Signed-off-by: Fabio Estevam <festevam@denx.de>
+---
+ Makefile | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+ create mode 100644 Makefile
+
+diff --git a/Makefile b/Makefile
+new file mode 100644
+index 0000000..71a4c9c
+--- /dev/null
++++ b/Makefile
+@@ -0,0 +1,16 @@
++prefix ?= /usr
++bindir ?= $(prefix)/bin
++
++EXEC = rtc-range rtc rtc-sync
++
++all: $(EXEC)
++
++clean:
++	$(RM) $(EXEC)
++
++install:
++	install -d $(DESTDIR)$(bindir)
++	install $(EXEC) $(DESTDIR)$(bindir)
++
++uninstall:
++	$(RM) -r $(addprefix $(DESTDIR)$(bindir)/,$(EXEC))
+--
+2.25.1
diff --git a/meta-oe/recipes-support/rtc-tools/rtc-tools_1.0.0.bb b/meta-oe/recipes-support/rtc-tools/rtc-tools_1.0.0.bb
new file mode 100644
index 000000000000..303585a6591d
--- /dev/null
+++ b/meta-oe/recipes-support/rtc-tools/rtc-tools_1.0.0.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "Useful programs to test rtc drivers"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=74274e8a218423e49eefdea80bc55038"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/abelloni/${BPN}.git;protocol=https;branch=master \
+           file://0001-rtc-tools-Add-a-Makefile.patch \
+           "
+SRCREV = "acc442e7af4e1e783432a43d37f1a7938c692659"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "DESTDIR=${D}"
+
+do_install() {
+	oe_runmake install
+}