diff mbox series

[meta-networking] libcoap: upgrade 4.3.1 -> 4.3.3

Message ID 1695108965-7312-1-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-networking] libcoap: upgrade 4.3.1 -> 4.3.3 | expand

Commit Message

Mingyu Wang (Fujitsu) Sept. 19, 2023, 7:36 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update:
 Copyright: Update copyright date to end 2023 as appropriate
 Add in OSCORE support
 RIOT: Update to support latest libcoap code
 Add BSD-3-Clause

Changelog:
===========
* Source files reformatted according to pre-commit rules.
* Support for RFC8613 (OSCORE).
* Support for RFC8974 (Extended Tokens).
* Support for RFC9177 (Q-Block).
* Support for latest RIOT code and new examples.
* Support for MinGW builds.
* Support for AF_UNIX sockets.
* Support for WebSockets (RFC8323).
* Support for IPv4 only and IPv6 only libcoap builds.
* Support for defining maximum logging level.
* Support for maintaining Observer requests over server restarts.
* Support for Contiki-NG.
* Support for latest LwIP, including using TinyDTLS.
* libcoap now has protocol layered support, separating out the
  logical layers. Stack now is:-
    - Application
    - libcoap - CoAP
    - libcoap - CoAP-Session
    - libcoap - (D)TLS I/F using external (D)TLS Library
    - libcoap - Netif
    - libcoap - Sockets
    - Kernel Network Stack
* Fixes CVE-2023-30362 and CVE-2023-35862.
* Reported bugs fixed.
* Examples now support separate logging levels for libcoap and (D)TLS.
* syslog LOG_ logging levels replaced with COAP_LOG_ logging levels.
* New public API functions to aid / reduce application coding.
* Remove requirement for applications to have sockaddr knowledge.
* Support for clients sending IPv4 broadcast requests.
* Documentation added and updated (Doxygen and man).
* Fix ABI version.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../libcoap/{libcoap_4.3.1.bb => libcoap_4.3.3.bb}          | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
 rename meta-networking/recipes-devtools/libcoap/{libcoap_4.3.1.bb => libcoap_4.3.3.bb} (92%)
diff mbox series

Patch

diff --git a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.3.bb
similarity index 92%
rename from meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
rename to meta-networking/recipes-devtools/libcoap/libcoap_4.3.3.bb
index efea3fab74..6e5bc07c59 100644
--- a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
+++ b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.3.bb
@@ -4,13 +4,13 @@  devices that are constrained their resources such as computing power, \
 RF range, memory, bandwith, or network packet sizes."
 HOMEPAGE ="https://libcoap.net/"
 
-LICENSE = "BSD-2-Clause & BSD-1-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0fbe4435d52b2d27a16f980ffc8ffc80"
+LICENSE = "BSD-2-Clause & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1978dbc41673ab1c20e64b287c8317bc"
 
 SRC_URI = "git://github.com/obgm/libcoap.git;branch=main;protocol=https \
            file://run-ptest \
            "
-SRCREV = "02b76470ab9168947152c78ad50835bf043d7c84"
+SRCREV = "9cde7cdee171e3f47486c6e70d479fdf49f3d2d6"
 
 S = "${WORKDIR}/git"