diff mbox series

[meta-oe] libxmlb: fix a reproducibility and runtime issue with ptest

Message ID 20230916174915.306571-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-oe] libxmlb: fix a reproducibility and runtime issue with ptest | expand

Commit Message

Markus Volk Sept. 16, 2023, 5:49 p.m. UTC
- add missing HOMEPAGE entry

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...xb-selftest.c-hardcode-G_TEST_SRCDIR.patch | 35 +++++++++++++++++++
 .../recipes-gnome/libxmlb/libxmlb_0.3.14.bb   | 15 ++++----
 2 files changed, 43 insertions(+), 7 deletions(-)
 create mode 100644 meta-oe/recipes-gnome/libxmlb/libxmlb/0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-gnome/libxmlb/libxmlb/0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch b/meta-oe/recipes-gnome/libxmlb/libxmlb/0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch
new file mode 100644
index 000000000..da8ce68df
--- /dev/null
+++ b/meta-oe/recipes-gnome/libxmlb/libxmlb/0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch
@@ -0,0 +1,35 @@ 
+From dc208bafc57c1ccaa0ca260f99c8b4c976271ebc Mon Sep 17 00:00:00 2001
+From: Markus Volk <f_l_k@t-online.de>
+Date: Sat, 16 Sep 2023 14:02:57 +0200
+Subject: [PATCH] xb-self-test.c: hardcode G_TEST_SRCDIR
+
+This avoids:
+ libxmlb-0.3.14-r0 do_package_qa: QA Issue: File
+ /usr/libexec/installed-tests/libxmlb/xb-self-test in package libxmlb-ptest
+ contains reference to TMPDIR [buildpaths]
+
+and also fixes the runtime for the ptest.
+
+Upstream-Status: Inappropriate [oe-specific]
+
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
+---
+ src/xb-self-test.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/xb-self-test.c b/src/xb-self-test.c
+index 47d9728..8b3dd0e 100644
+--- a/src/xb-self-test.c
++++ b/src/xb-self-test.c
+@@ -2870,7 +2870,7 @@ xb_speed_func(void)
+ int
+ main(int argc, char **argv)
+ {
+-	g_setenv("G_TEST_SRCDIR", SRCDIR, FALSE);
++	g_setenv("G_TEST_SRCDIR", "/usr/libexec/installed-tests/libxmlb", FALSE);
+ 
+ 	g_test_init(&argc, &argv, NULL);
+ 
+-- 
+2.41.0
+
diff --git a/meta-oe/recipes-gnome/libxmlb/libxmlb_0.3.14.bb b/meta-oe/recipes-gnome/libxmlb/libxmlb_0.3.14.bb
index d46811124..1d3b0de29 100644
--- a/meta-oe/recipes-gnome/libxmlb/libxmlb_0.3.14.bb
+++ b/meta-oe/recipes-gnome/libxmlb/libxmlb_0.3.14.bb
@@ -1,10 +1,13 @@ 
 SUMMARY = "A library to help create and query binary XML blobs"
+HOMEPAGE = "https://github.com/hughsie/libxmlb"
 LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
 
-SRC_URI = "git://github.com/hughsie/libxmlb.git;branch=main;protocol=https \
-           file://run-ptest \
-           "
+SRC_URI = " \
+	git://github.com/hughsie/libxmlb.git;branch=main;protocol=https \
+	file://0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch \
+	file://run-ptest \
+"
 SRCREV = "aa577b276adc66564f5777f9a522ca3bf0bfa65e"
 S = "${WORKDIR}/git"
 
@@ -12,13 +15,11 @@  DEPENDS = "glib-2.0 xz zstd"
 
 inherit gobject-introspection gtk-doc meson ptest-gnome lib_package pkgconfig
 
-PACKAGECONFIG ??= "\
-    ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
-"
+PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
 PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
 
 GTKDOC_MESON_OPTION = "gtkdoc"
 
-FILES:${PN}-bin += "${libexecdir}/*"
+FILES:${PN} += "${datadir}"
 
 BBCLASSEXTEND = "native"