diff mbox series

[2/3] util-linux: Disable failing tests on musl

Message ID 20230915153415.3241307-2-raj.khem@gmail.com
State Accepted, archived
Commit 0190b3eb67d02ecf42531a7c087a5a6f75ee7a5e
Headers show
Series [1/3] util-linux: Fix lscpu on musl | expand

Commit Message

Khem Raj Sept. 15, 2023, 3:34 p.m. UTC
These tests need strptime with %s which is glibc specific extention

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/util-linux/util-linux_2.39.1.bb | 9 +++++++++
 1 file changed, 9 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-core/util-linux/util-linux_2.39.1.bb b/meta/recipes-core/util-linux/util-linux_2.39.1.bb
index c81405533c4..821a44a1453 100644
--- a/meta/recipes-core/util-linux/util-linux_2.39.1.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.39.1.bb
@@ -322,3 +322,12 @@  do_install_ptest() {
         rm -rf ${D}${PTEST_PATH}/tests/ts/chfn
     fi
 }
+
+# Delete tests not working on musl
+do_install_ptest:append:libc-musl() {
+    for t in tests/ts/col/multibyte \
+            tests/ts/lib/timeutils \
+            tests/ts/dmesg/limit; do
+        rm -rf ${D}${PTEST_PATH}/$t
+    done
+}