diff mbox series

[meta-multimedia,1/2] webrtc-audio-processing: add recipe for 1.x

Message ID 20230914130631.182859-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-multimedia,1/2] webrtc-audio-processing: add recipe for 1.x | expand

Commit Message

Markus Volk Sept. 14, 2023, 1:06 p.m. UTC
Starting with 0.3.80 pipewire has a minimum requirement on
webrtc-audio-processing-1

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../webrtc-audio-processing-1_1.3.bb            | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-multimedia/recipes-multimedia/webrtc-audio-processing/webrtc-audio-processing-1_1.3.bb

Comments

Khem Raj Sept. 14, 2023, 2:28 p.m. UTC | #1
On Thu, Sep 14, 2023 at 6:08 AM Markus Volk <f_l_k@t-online.de> wrote:
>
> Starting with 0.3.80 pipewire has a minimum requirement on
> webrtc-audio-processing-1
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  .../webrtc-audio-processing-1_1.3.bb            | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-multimedia/recipes-multimedia/webrtc-audio-processing/webrtc-audio-processing-1_1.3.bb
>
> diff --git a/meta-multimedia/recipes-multimedia/webrtc-audio-processing/webrtc-audio-processing-1_1.3.bb b/meta-multimedia/recipes-multimedia/webrtc-audio-processing/webrtc-audio-processing-1_1.3.bb
> new file mode 100644
> index 000000000..d07772f1b
> --- /dev/null
> +++ b/meta-multimedia/recipes-multimedia/webrtc-audio-processing/webrtc-audio-processing-1_1.3.bb
> @@ -0,0 +1,17 @@
> +DESCRIPTION = "Audio processing bits of the WebRTC reference implementation"
> +HOMEPAGE = "https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
> +SECTION = "audio"
> +
> +DEPENDS = "abseil-cpp"
> +DEPENDS:append:libc-musl = " libexecinfo"
> +
> +LICENSE = "BSD-3-Clause"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=da08a38a32a340c5d91e13ee86a118f2"
> +
> +SRC_URI = "http://freedesktop.org/software/pulseaudio/webrtc-audio-processing/webrtc-audio-processing-${PV}.tar.xz"
> +SRC_URI[sha256sum] = "2365e93e778d7b61b5d6e02d21c47d97222e9c7deff9e1d0838ad6ec2e86f1b9"
> +S = "${WORKDIR}/webrtc-audio-processing-${PV}"

This setting S is redundant so remove it.

> +
> +LDFLAGS:append:libc-musl = " -lexecinfo"
> +
> +inherit meson pkgconfig
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104867): https://lists.openembedded.org/g/openembedded-devel/message/104867
> Mute This Topic: https://lists.openembedded.org/mt/101357605/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Markus Volk Sept. 14, 2023, 2:32 p.m. UTC | #2
On Thu, Sep 14 2023 at 07:28:21 AM -07:00:00, Khem Raj 
<raj.khem@gmail.com> wrote:
> This setting S is redundant so remove it.

I think it isn't, because without setting that to 
'webrtc-audio-processing-1.3" it would expect S to be 
webrtc-audio-processing-1-1.3

By the way, the build failed for musl. I'll send an update
Khem Raj Sept. 14, 2023, 2:35 p.m. UTC | #3
On Thu, Sep 14, 2023 at 7:32 AM Markus Volk <f_l_k@t-online.de> wrote:
>
> On Thu, Sep 14 2023 at 07:28:21 AM -07:00:00, Khem Raj <raj.khem@gmail.com> wrote:
>
> This setting S is redundant so remove it.
>
>
> I think it isn't, because without setting that to 'webrtc-audio-processing-1.3" it would expect S to be webrtc-audio-processing-1-1.3

ah NOCOFFEEYET error on my end.

>
> By the way, the build failed for musl. I'll send an update
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/webrtc-audio-processing/webrtc-audio-processing-1_1.3.bb b/meta-multimedia/recipes-multimedia/webrtc-audio-processing/webrtc-audio-processing-1_1.3.bb
new file mode 100644
index 000000000..d07772f1b
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/webrtc-audio-processing/webrtc-audio-processing-1_1.3.bb
@@ -0,0 +1,17 @@ 
+DESCRIPTION = "Audio processing bits of the WebRTC reference implementation"
+HOMEPAGE = "https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
+SECTION = "audio"
+
+DEPENDS = "abseil-cpp"
+DEPENDS:append:libc-musl = " libexecinfo"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=da08a38a32a340c5d91e13ee86a118f2"
+
+SRC_URI = "http://freedesktop.org/software/pulseaudio/webrtc-audio-processing/webrtc-audio-processing-${PV}.tar.xz"
+SRC_URI[sha256sum] = "2365e93e778d7b61b5d6e02d21c47d97222e9c7deff9e1d0838ad6ec2e86f1b9"
+S = "${WORKDIR}/webrtc-audio-processing-${PV}"
+
+LDFLAGS:append:libc-musl = " -lexecinfo"
+
+inherit meson pkgconfig