Patchwork [meta-openembedded] lighttpd: Set SYSTEMD_PACKAGES as lighttpd-systemd.

login
register
mail settings
Submitter Elvis Dowson
Date June 22, 2012, 3:48 a.m.
Message ID <1340336931-7978-1-git-send-email-elvis.dowson@gmail.com>
Download mbox | patch
Permalink /patch/30441/
State Superseded
Headers show

Comments

Elvis Dowson - June 22, 2012, 3:48 a.m.
This commit fixes WARNING:
/tool/yocto/poky/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb:
it is recommended to set SYSTEMD_PACKAGES as <existing-package>-systemd

Signed-off-by: Elvis Dowson <elvis.dowson@gmail.com>
---
 .../lighttpd/lighttpd_1.4.30.bbappend              |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Elvis Dowson - June 28, 2012, 5:09 p.m.
Hi,
      I sent this patch a while back, and this still hasn't been applied. I just did a git pull and noticed this. Its a trivial patch, so would it be possible for someone to please apply it.

Elvis

On Jun 22, 2012, at 7:48 AM, Elvis Dowson wrote:

> This commit fixes WARNING:
> /tool/yocto/poky/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb:
> it is recommended to set SYSTEMD_PACKAGES as <existing-package>-systemd
> 
> Signed-off-by: Elvis Dowson <elvis.dowson@gmail.com>
> ---
> .../lighttpd/lighttpd_1.4.30.bbappend              |    2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
> index 1341405..b02f35c 100644
> --- a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
> +++ b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
> @@ -6,5 +6,5 @@ inherit systemd
> 
> SRC_URI += "file://lighttpd.service"
> 
> -SYSTEMD_PACKAGES = "${PN}"
> +SYSTEMD_PACKAGES = "${PN}-systemd"
> SYSTEMD_SERVICE_${PN} = "lighttpd.service"
> -- 
> 1.7.9.5
>
Martin Jansa - June 28, 2012, 5:34 p.m.
On Thu, Jun 28, 2012 at 09:09:37PM +0400, Elvis Dowson wrote:
> Hi,
>       I sent this patch a while back, and this still hasn't been applied. I just did a git pull and noticed this. Its a trivial patch, so would it be possible for someone to please apply it.

It's trivial but if some image or task had lighttpd in RDEPENDS then it
got also systemd support with it.. so those images/tasks need to be
fixed too.

I don't have such task/image, just explaining that it's not so trivial
as this..

Cheers,

> 
> Elvis
> 
> On Jun 22, 2012, at 7:48 AM, Elvis Dowson wrote:
> 
> > This commit fixes WARNING:
> > /tool/yocto/poky/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb:
> > it is recommended to set SYSTEMD_PACKAGES as <existing-package>-systemd
> > 
> > Signed-off-by: Elvis Dowson <elvis.dowson@gmail.com>
> > ---
> > .../lighttpd/lighttpd_1.4.30.bbappend              |    2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
> > index 1341405..b02f35c 100644
> > --- a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
> > +++ b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
> > @@ -6,5 +6,5 @@ inherit systemd
> > 
> > SRC_URI += "file://lighttpd.service"
> > 
> > -SYSTEMD_PACKAGES = "${PN}"
> > +SYSTEMD_PACKAGES = "${PN}-systemd"
> > SYSTEMD_SERVICE_${PN} = "lighttpd.service"
> > -- 
> > 1.7.9.5
> > 
> 
> 
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
Elvis Dowson - June 28, 2012, 5:40 p.m.
HI Martin,

On Jun 28, 2012, at 9:34 PM, Martin Jansa wrote:

> On Thu, Jun 28, 2012 at 09:09:37PM +0400, Elvis Dowson wrote:
>> I sent this patch a while back, and this still hasn't been applied. I just did a git pull and noticed this. Its a trivial patch, so would it be possible for someone to please apply it.
> 
> It's trivial but if some image or task had lighttpd in RDEPENDS then it
> got also systemd support with it.. so those images/tasks need to be
> fixed too.

I did a full clean build, and the last three patches squashed all warnings for the following layers:

BBLAYERS ?= " \
  /tool/yocto/poky/meta \
  /tool/yocto/poky/meta-yocto \
  /tool/yocto/meta-openembedded/meta-oe \
  /tool/yocto/meta-xilinx \
  "

I guess if someone else encounters some issues, they can fix recipes in their meta-layers accordingly.

Best regards,

Elvis Dowson

Patch

diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
index 1341405..b02f35c 100644
--- a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
+++ b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
@@ -6,5 +6,5 @@  inherit systemd
 
 SRC_URI += "file://lighttpd.service"
 
-SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_PACKAGES = "${PN}-systemd"
 SYSTEMD_SERVICE_${PN} = "lighttpd.service"