[2/3] Revert "meta-arm-bsp: use old python3-crytography on platforms using TF-M"

Message ID 20220127165419.952245-2-ross.burton@arm.com
State New
Headers show
Series [1/3] arm/trusted-firmware-m: set OpenSSL provider path | expand

Commit Message

Ross Burton Jan. 27, 2022, 4:54 p.m. UTC
This reverts commit 2a27bd4f47d09bb709a953f4a91ef2a2cf921255.
---
 meta-arm-bsp/conf/layer.conf                       | 6 +-----
 meta-arm-bsp/conf/machine/include/corstone1000.inc | 5 -----
 meta-arm-bsp/conf/machine/musca-b1.conf            | 5 -----
 meta-arm-bsp/conf/machine/musca-s1.conf            | 5 -----
 4 files changed, 1 insertion(+), 20 deletions(-)

Patch

diff --git a/meta-arm-bsp/conf/layer.conf b/meta-arm-bsp/conf/layer.conf
index 82230470..45767866 100644
--- a/meta-arm-bsp/conf/layer.conf
+++ b/meta-arm-bsp/conf/layer.conf
@@ -21,8 +21,4 @@  LAYERDEPENDS_meta-arm-bsp:append:musca-s1 = " meta-python"
 LICENSE_PATH += "${LAYERDIR}/custom-licenses"
 
 # Delete this when our downgrade of python3-cryptography is removed
-META_ARM_PYCRYPTO = "meta-arm-bsp/recipes-devtools/python/python3-cryptography_3.3.2.bb"
-META_ARM_PYCRYPTO:corstone1000 = ""
-META_ARM_PYCRYPTO:musca-b1 = ""
-META_ARM_PYCRYPTO:musca-s1 = ""
-BBMASK += "${META_ARM_PYCRYPTO}"
+BBMASK += "meta-arm-bsp/recipes-devtools/python/python3-cryptography_3.3.2.bb"
diff --git a/meta-arm-bsp/conf/machine/include/corstone1000.inc b/meta-arm-bsp/conf/machine/include/corstone1000.inc
index 019293b0..f9d301e4 100644
--- a/meta-arm-bsp/conf/machine/include/corstone1000.inc
+++ b/meta-arm-bsp/conf/machine/include/corstone1000.inc
@@ -63,8 +63,3 @@  SERIAL_CONSOLES ?= "115200;ttyAMA0"
 WKS_FILE_DEPENDS:append = " ${EXTRA_IMAGEDEPENDS}"
 
 WKS_FILE ?= "corstone1000-image.corstone1000.wks"
-
-# The latest python3-cryptography-native doesn't work
-# (cryptography.exceptions.InternalError: Unknown OpenSSL error) so use the
-# version before Rust was involved for now.
-PREFERRED_VERSION_python3-cryptography-native = "3.3.2"
diff --git a/meta-arm-bsp/conf/machine/musca-b1.conf b/meta-arm-bsp/conf/machine/musca-b1.conf
index ec5ff4ee..073c466e 100644
--- a/meta-arm-bsp/conf/machine/musca-b1.conf
+++ b/meta-arm-bsp/conf/machine/musca-b1.conf
@@ -26,8 +26,3 @@  ZEPHYR_INHERIT_CLASSES += "zephyr-qemuboot"
 ARCH:musca-b1 = "arm"
 
 TFM_PLATFORM = "arm/musca_b1/sse_200"
-
-# The latest python3-cryptography-native doesn't work
-# (cryptography.exceptions.InternalError: Unknown OpenSSL error) so use the
-# version before Rust was involved for now.
-PREFERRED_VERSION_python3-cryptography-native = "3.3.2"
diff --git a/meta-arm-bsp/conf/machine/musca-s1.conf b/meta-arm-bsp/conf/machine/musca-s1.conf
index e5f63f76..d18c06c2 100644
--- a/meta-arm-bsp/conf/machine/musca-s1.conf
+++ b/meta-arm-bsp/conf/machine/musca-s1.conf
@@ -25,8 +25,3 @@  ZEPHYR_INHERIT_CLASSES += "zephyr-qemuboot"
 ARCH:musca-s1 = "arm"
 
 TFM_PLATFORM = "arm/musca_s1"
-
-# The latest python3-cryptography-native doesn't work
-# (cryptography.exceptions.InternalError: Unknown OpenSSL error) so use the
-# version before Rust was involved for now.
-PREFERRED_VERSION_python3-cryptography-native = "3.3.2"