diff mbox series

[meta-oe] libei: add recipe

Message ID 20230908100500.755300-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-oe] libei: add recipe | expand

Commit Message

Markus Volk Sept. 8, 2023, 10:05 a.m. UTC
libei is a library for Emulated Input, primarily aimed at the Wayland stack.
It uses a typical client/server separation, with the two parts connected via
a UNIX socket. In libei parlance, the client-side is called “EI client”, the
server side, typically a Wayland compositor, is called the “EIS Implementation”
(Emulated Input Server).

libei is a required dependency for the upcoming mutter-45 release

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../recipes-graphics/wayland/libei_1.1.0.bb   | 25 +++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 meta-oe/recipes-graphics/wayland/libei_1.1.0.bb
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/wayland/libei_1.1.0.bb b/meta-oe/recipes-graphics/wayland/libei_1.1.0.bb
new file mode 100644
index 000000000..1727ef9be
--- /dev/null
+++ b/meta-oe/recipes-graphics/wayland/libei_1.1.0.bb
@@ -0,0 +1,25 @@ 
+SUMMARY = "libei is a library for Emulated Input, primarily aimed at the Wayland stack."
+HOMEPAGE = "https://gitlab.freedesktop.org/libinput/libei"
+SECTION = "graphics"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=a98fa76460f96f41696611d6f07e8d49"
+
+DEPENDS = " \
+	libxkbcommon \
+	libevdev \
+	libxslt-native \
+	python3-attrs-native \
+	python3-jinja2-native \
+	${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'basu', d)} \
+"
+
+SRC_URI = "git://gitlab.freedesktop.org/libinput/libei.git;protocol=https;branch=main"
+
+S = "${WORKDIR}/git"
+SRCREV = "82cdbc9129a0e2c255fcee6bcaa7abed5578ae14"
+
+inherit meson pkgconfig
+
+EXTRA_OEMESON = "-Dtests=disabled"
+