diff mbox series

perl: Add packageconfig for setlocale functionality differences

Message ID 20230908053241.684488-1-raj.khem@gmail.com
State Accepted, archived
Commit e9e22c74d0544271f3e43c67fbf95f2e68400da0
Headers show
Series perl: Add packageconfig for setlocale functionality differences | expand

Commit Message

Khem Raj Sept. 8, 2023, 5:32 a.m. UTC
setlocale behavior with 'missing' locales is different when using musl
[1] which confuses perl locale tests and perl thinks it has locale on
system while there are none. Therefore pass correct property on musl
regarding setlocale behaviour

[1] https://musl.openwall.narkive.com/kO1vpTWJ/setlocale-behavior-with-missing-locales

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/perl/perl_5.38.0.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/perl/perl_5.38.0.bb b/meta/recipes-devtools/perl/perl_5.38.0.bb
index 2103a39dfa4..a8623b6e84b 100644
--- a/meta/recipes-devtools/perl/perl_5.38.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.38.0.bb
@@ -38,8 +38,10 @@  DEPENDS += "make-native"
 PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"
 
 PACKAGECONFIG ??= "gdbm"
+PACKAGECONFIG:append:libc-musl = " anylocale"
 PACKAGECONFIG[bdb] = ",-Ui_db,db"
 PACKAGECONFIG[gdbm] = ",-Ui_gdbm,gdbm"
+PACKAGECONFIG[anylocale] = "-Dd_setlocale_accepts_any_locale_name=define,,"
 
 # Don't generate comments in enc2xs output files. They are not reproducible
 export ENC2XS_NO_COMMENTS = "1"