diff mbox series

[meta-oe,master] meta-oe-components: Avoid usage of nobranch=1

Message ID 20230904122854.74649-1-pramanik.souravkumar@gmail.com
State New
Headers show
Series [meta-oe,master] meta-oe-components: Avoid usage of nobranch=1 | expand

Commit Message

Sourav Pramanik Sept. 4, 2023, 12:28 p.m. UTC
The usage of nobranch=1 in SRC_URI allows using unprotected branches.

This change updates the real branch name in place of nobranch=1 for these components.

Signed-off-by: Sourav Kumar Pramanik <pramanik.souravkumar@gmail.com>
---
 meta-gnome/recipes-connectivity/geary/geary_40.0.bb             | 2 +-
 meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb    | 2 +-
 .../dynamic-layers/meta-python/recipes-bsp/rwmem/rwmem_1.2.bb   | 2 +-
 meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb              | 2 +-
 meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb               | 2 +-
 meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb                     | 2 +-
 meta-oe/recipes-support/glog/glog_0.5.0.bb                      | 2 +-
 meta-oe/recipes-support/libmxml/libmxml_3.3.bb                  | 2 +-
 8 files changed, 8 insertions(+), 8 deletions(-)

Comments

Khem Raj Sept. 5, 2023, 12:25 a.m. UTC | #1
Please rebase on top of master-next and resend

On Mon, Sep 4, 2023 at 5:31 AM Sourav Kumar Pramanik <
pramanik.souravkumar@gmail.com> wrote:

> The usage of nobranch=1 in SRC_URI allows using unprotected branches.
>
> This change updates the real branch name in place of nobranch=1 for these
> components.
>
> Signed-off-by: Sourav Kumar Pramanik <pramanik.souravkumar@gmail.com>
> ---
>  meta-gnome/recipes-connectivity/geary/geary_40.0.bb             | 2 +-
>  meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb    | 2 +-
>  .../dynamic-layers/meta-python/recipes-bsp/rwmem/rwmem_1.2.bb   | 2 +-
>  meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb              | 2 +-
>  meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb               | 2 +-
>  meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb                     | 2 +-
>  meta-oe/recipes-support/glog/glog_0.5.0.bb                      | 2 +-
>  meta-oe/recipes-support/libmxml/libmxml_3.3.bb                  | 2 +-
>  8 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
> b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
> index 501b27a54..7faa69c55 100644
> --- a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
> +++ b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
> @@ -33,7 +33,7 @@ RDEPENDS:${PN} = "gnome-keyring"
>  inherit meson pkgconfig mime-xdg gtk-icon-cache gobject-introspection
> vala features_check
>
>  SRC_URI = " \
> -       git://github.com/GNOME/geary.git;nobranch=1;protocol=https \
> +       git://github.com/GNOME/geary.git;branch=main;protocol=https \
>
>  file://0001-Util.Cache.Lru-Workaround-missing-generic-type-argum.patch \
>
>  file://0002-Fix-accessibility-issues-with-initializer-of-constan.patch \
>  "
> diff --git a/meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb
> b/meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb
> index 9f2ff5157..c7cd21b6b 100644
> --- a/meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb
> +++ b/meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb
> @@ -4,7 +4,7 @@ SECTION = "libs"
>  LICENSE = "BSD-3-Clause"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=0036c1b155f4e999f3e0a373490b5db9"
>
> -SRC_URI = "git://github.com/dugsong/libdnet.git;nobranch=1;protocol=https
> "
> +SRC_URI = "git://
> github.com/dugsong/libdnet.git;branch=master;protocol=https"
>  SRCREV = "3e782472d2a58d5e1b94d04eda4a364c2d257600"
>
>  UPSTREAM_CHECK_GITTAGREGEX = "libdnet-(?P<pver>\d+(\.\d+)+)"
> diff --git a/meta-oe/dynamic-layers/meta-python/recipes-bsp/rwmem/
> rwmem_1.2.bb b/meta-oe/dynamic-layers/meta-python/recipes-bsp/rwmem/
> rwmem_1.2.bb
> index 7bca24cc0..b59fc1bc9 100644
> --- a/meta-oe/dynamic-layers/meta-python/recipes-bsp/rwmem/rwmem_1.2.bb
> +++ b/meta-oe/dynamic-layers/meta-python/recipes-bsp/rwmem/rwmem_1.2.bb
> @@ -22,7 +22,7 @@ SRCREV_FORMAT = "rwmem_inih"
>
>  SRC_URI = " \
>      git://
> github.com/tomba/rwmem.git;protocol=https;name=rwmem;branch=master \
> -    git://
> github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih
> \
> +    git://
> github.com/benhoyt/inih.git;protocol=https;name=inih;branch=master;destsuffix=git/ext/inih
> \
>  "
>
>  S = "${WORKDIR}/git"
> diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
> b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
> index cf33c6904..7f93f704e 100644
> --- a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
> +++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
> @@ -9,7 +9,7 @@ LICENSE = "MIT"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
>
>  # TODO: Pin upstream release (current v7.11.0-80-g419a757)
> -SRC_URI = "git://github.com/lvgl/lv_drivers;protocol=https;nobranch=1"
> +SRC_URI = "git://github.com/lvgl/lv_drivers;protocol=https;branch=master"
>  SRCREV = "419a757c23aaa67c676fe3a2196d64808fcf2254"
>
>  DEPENDS = "libxkbcommon lvgl wayland"
> diff --git a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
> b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
> index 22b482640..0049bbe23 100644
> --- a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
> +++ b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
> @@ -8,7 +8,7 @@ DESCRIPTION = "Allow the use of PNG images in LVGL. This
> implementation uses lod
>  LICENSE = "MIT"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
>
> -SRC_URI = "git://github.com/lvgl/lv_lib_png;;protocol=https;nobranch=1"
> +SRC_URI = "git://github.com/lvgl/lv_lib_png;;protocol=https;branch=master
> "
>  SRCREV = "bf1531afe07c9f861107559e29ab8a2d83e4715a"
>
>  S = "${WORKDIR}/git"
> diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
> b/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
> index ea74c5918..0021da01f 100644
> --- a/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
> +++ b/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
> @@ -8,7 +8,7 @@ SUMMARY = "Light and Versatile Graphics Library"
>  LICENSE = "MIT"
>  LIC_FILES_CHKSUM =
> "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
>
> -SRC_URI = "gitsm://github.com/lvgl/lvgl;protocol=https;nobranch=1"
> +SRC_URI = "gitsm://github.com/lvgl/lvgl;protocol=https;branch=master"
>  SRCREV = "d38eb1e689fa5a64c25e677275172d9c8a4ab2f0"
>
>  REQUIRED_DISTRO_FEATURES = "wayland"
> diff --git a/meta-oe/recipes-support/glog/glog_0.5.0.bb
> b/meta-oe/recipes-support/glog/glog_0.5.0.bb
> index 61581d96d..f0b129396 100644
> --- a/meta-oe/recipes-support/glog/glog_0.5.0.bb
> +++ b/meta-oe/recipes-support/glog/glog_0.5.0.bb
> @@ -7,7 +7,7 @@ LICENSE = "BSD-3-Clause"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
>
>  SRC_URI = " \
> -    git://github.com/google/glog.git;nobranch=1;protocol=https \
> +    git://github.com/google/glog.git;branch=master;protocol=https \
>      file://libexecinfo.patch \
>  "
>
> diff --git a/meta-oe/recipes-support/libmxml/libmxml_3.3.bb
> b/meta-oe/recipes-support/libmxml/libmxml_3.3.bb
> index c8e216779..5169337f5 100644
> --- a/meta-oe/recipes-support/libmxml/libmxml_3.3.bb
> +++ b/meta-oe/recipes-support/libmxml/libmxml_3.3.bb
> @@ -4,7 +4,7 @@ LIC_FILES_CHKSUM =
> "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
>  HOMEPAGE = "https://www.msweet.org/mxml/"
>  BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
>
> -SRC_URI = "git://
> github.com/michaelrsweet/mxml.git;nobranch=1;protocol=https"
> +SRC_URI = "git://
> github.com/michaelrsweet/mxml.git;branch=master;protocol=https"
>  SRCREV = "0237559fdbcecae34157b547aa2b99e12de305a2"
>  S = "${WORKDIR}/git"
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104711):
> https://lists.openembedded.org/g/openembedded-devel/message/104711
> Mute This Topic: https://lists.openembedded.org/mt/101147022/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
index 501b27a54..7faa69c55 100644
--- a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
+++ b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
@@ -33,7 +33,7 @@  RDEPENDS:${PN} = "gnome-keyring"
 inherit meson pkgconfig mime-xdg gtk-icon-cache gobject-introspection vala features_check
 
 SRC_URI = " \
-	git://github.com/GNOME/geary.git;nobranch=1;protocol=https \
+	git://github.com/GNOME/geary.git;branch=main;protocol=https \
         file://0001-Util.Cache.Lru-Workaround-missing-generic-type-argum.patch \
         file://0002-Fix-accessibility-issues-with-initializer-of-constan.patch \
 "
diff --git a/meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb b/meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb
index 9f2ff5157..c7cd21b6b 100644
--- a/meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb
+++ b/meta-networking/recipes-connectivity/libdnet/libdnet_1.14.bb
@@ -4,7 +4,7 @@  SECTION = "libs"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=0036c1b155f4e999f3e0a373490b5db9"
 
-SRC_URI = "git://github.com/dugsong/libdnet.git;nobranch=1;protocol=https"
+SRC_URI = "git://github.com/dugsong/libdnet.git;branch=master;protocol=https"
 SRCREV = "3e782472d2a58d5e1b94d04eda4a364c2d257600"
 
 UPSTREAM_CHECK_GITTAGREGEX = "libdnet-(?P<pver>\d+(\.\d+)+)"
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-bsp/rwmem/rwmem_1.2.bb b/meta-oe/dynamic-layers/meta-python/recipes-bsp/rwmem/rwmem_1.2.bb
index 7bca24cc0..b59fc1bc9 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-bsp/rwmem/rwmem_1.2.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-bsp/rwmem/rwmem_1.2.bb
@@ -22,7 +22,7 @@  SRCREV_FORMAT = "rwmem_inih"
 
 SRC_URI = " \
     git://github.com/tomba/rwmem.git;protocol=https;name=rwmem;branch=master \
-    git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \
+    git://github.com/benhoyt/inih.git;protocol=https;name=inih;branch=master;destsuffix=git/ext/inih \
 "
 
 S = "${WORKDIR}/git"
diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
index cf33c6904..7f93f704e 100644
--- a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
@@ -9,7 +9,7 @@  LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
 
 # TODO: Pin upstream release (current v7.11.0-80-g419a757)
-SRC_URI = "git://github.com/lvgl/lv_drivers;protocol=https;nobranch=1"
+SRC_URI = "git://github.com/lvgl/lv_drivers;protocol=https;branch=master"
 SRCREV = "419a757c23aaa67c676fe3a2196d64808fcf2254"
 
 DEPENDS = "libxkbcommon lvgl wayland"
diff --git a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
index 22b482640..0049bbe23 100644
--- a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
+++ b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
@@ -8,7 +8,7 @@  DESCRIPTION = "Allow the use of PNG images in LVGL. This implementation uses lod
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
 
-SRC_URI = "git://github.com/lvgl/lv_lib_png;;protocol=https;nobranch=1"
+SRC_URI = "git://github.com/lvgl/lv_lib_png;;protocol=https;branch=master"
 SRCREV = "bf1531afe07c9f861107559e29ab8a2d83e4715a"
 
 S = "${WORKDIR}/git"
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb b/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
index ea74c5918..0021da01f 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
@@ -8,7 +8,7 @@  SUMMARY = "Light and Versatile Graphics Library"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
 
-SRC_URI = "gitsm://github.com/lvgl/lvgl;protocol=https;nobranch=1"
+SRC_URI = "gitsm://github.com/lvgl/lvgl;protocol=https;branch=master"
 SRCREV = "d38eb1e689fa5a64c25e677275172d9c8a4ab2f0"
 
 REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/meta-oe/recipes-support/glog/glog_0.5.0.bb b/meta-oe/recipes-support/glog/glog_0.5.0.bb
index 61581d96d..f0b129396 100644
--- a/meta-oe/recipes-support/glog/glog_0.5.0.bb
+++ b/meta-oe/recipes-support/glog/glog_0.5.0.bb
@@ -7,7 +7,7 @@  LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
 
 SRC_URI = " \
-    git://github.com/google/glog.git;nobranch=1;protocol=https \
+    git://github.com/google/glog.git;branch=master;protocol=https \
     file://libexecinfo.patch \
 "
 
diff --git a/meta-oe/recipes-support/libmxml/libmxml_3.3.bb b/meta-oe/recipes-support/libmxml/libmxml_3.3.bb
index c8e216779..5169337f5 100644
--- a/meta-oe/recipes-support/libmxml/libmxml_3.3.bb
+++ b/meta-oe/recipes-support/libmxml/libmxml_3.3.bb
@@ -4,7 +4,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 HOMEPAGE = "https://www.msweet.org/mxml/"
 BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
 
-SRC_URI = "git://github.com/michaelrsweet/mxml.git;nobranch=1;protocol=https"
+SRC_URI = "git://github.com/michaelrsweet/mxml.git;branch=master;protocol=https"
 SRCREV = "0237559fdbcecae34157b547aa2b99e12de305a2"
 S = "${WORKDIR}/git"