diff mbox series

[1/2] distcc: Fix groupname gid change warning

Message ID 20230831142305.10981-1-sweng5080@gmail.com
State New
Headers show
Series [1/2] distcc: Fix groupname gid change warning | expand

Commit Message

JD Schroeder Aug. 31, 2023, 2:23 p.m. UTC
This patch fixes warnings when useradd-staticids.bbclass is used and
USERADD_PARAM is used to add the user to a group that has not been
explicitly created yet. By adding the GROUPADD_PARAM for the new group
being used the warnings for changing the gid from GID-OLD to GID-NEW
is eliminated.

Warning fixed:
distcc: Changing groupname nogroup's gid from (WXYZ) to (JKLM), verify configuration files!

Signed-off-by: JD Schroeder <sweng5080@gmail.com>
---
 meta/recipes-devtools/distcc/distcc_3.4.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Alexandre Belloni Sept. 1, 2023, 10:03 a.m. UTC | #1
Hello,

This fails on the autobuilders:

https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/3449/steps/12/logs/stdio

ERROR: Nothing RPROVIDES 'distcc' (but /home/pokybuild/yocto-worker/reproducible/build/meta/recipes-core/packagegroups/packagegroup-self-hosted.bb, /home/pokybuild/yocto-worker/reproducible/build/meta/recipes-devtools/devel-config/distcc-config.bb RDEPENDS on or otherwise requires it)
distcc was skipped: Recipe distcc, package distcc-server: system groupname "nogroup" does not have a static ID defined. Add nogroup to one of these files: /home/pokybuild/yocto-worker/reproducible/build/build-st/meta-selftest/files/static-group


On 31/08/2023 09:23:04-0500, JD Schroeder wrote:
> This patch fixes warnings when useradd-staticids.bbclass is used and
> USERADD_PARAM is used to add the user to a group that has not been
> explicitly created yet. By adding the GROUPADD_PARAM for the new group
> being used the warnings for changing the gid from GID-OLD to GID-NEW
> is eliminated.
> 
> Warning fixed:
> distcc: Changing groupname nogroup's gid from (WXYZ) to (JKLM), verify configuration files!
> 
> Signed-off-by: JD Schroeder <sweng5080@gmail.com>
> ---
>  meta/recipes-devtools/distcc/distcc_3.4.bb | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/meta/recipes-devtools/distcc/distcc_3.4.bb b/meta/recipes-devtools/distcc/distcc_3.4.bb
> index 45fc7cde53..0c20f74d68 100644
> --- a/meta/recipes-devtools/distcc/distcc_3.4.bb
> +++ b/meta/recipes-devtools/distcc/distcc_3.4.bb
> @@ -33,6 +33,7 @@ EXTRA_OECONF += "--disable-Werror PYTHON='' --disable-pump-mode"
>  PACKAGE_BEFORE_PN = "${PN}-distmon-gnome ${PN}-server"
>  
>  USERADD_PACKAGES = "${PN}-server"
> +GROUPADD_PARAM:${PN}-server = "--system nogroup"
>  USERADD_PARAM:${PN}-server = "--system \
>                         --home /dev/null \
>                         --no-create-home \
> -- 
> 2.37.0
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#186977): https://lists.openembedded.org/g/openembedded-core/message/186977
> Mute This Topic: https://lists.openembedded.org/mt/101074670/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Ross Burton Sept. 12, 2023, 11:03 a.m. UTC | #2
On 1 Sep 2023, at 11:03, Alexandre Belloni via lists.openembedded.org <alexandre.belloni=bootlin.com@lists.openembedded.org> wrote:
> 
> Hello,
> 
> This fails on the autobuilders:
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/3449/steps/12/logs/stdio
> 
> ERROR: Nothing RPROVIDES 'distcc' (but /home/pokybuild/yocto-worker/reproducible/build/meta/recipes-core/packagegroups/packagegroup-self-hosted.bb, /home/pokybuild/yocto-worker/reproducible/build/meta/recipes-devtools/devel-config/distcc-config.bb RDEPENDS on or otherwise requires it)
> distcc was skipped: Recipe distcc, package distcc-server: system groupname "nogroup" does not have a static ID defined. Add nogroup to one of these files: /home/pokybuild/yocto-worker/reproducible/build/build-st/meta-selftest/files/static-group

The same problem would hit the ppp-dialin but that recipe doesn’t get built in the AB in an environment that has static IPs.

Ross
JD Schroeder Sept. 27, 2023, 1:07 p.m. UTC | #3
On Tue, Sep 12, 2023 at 06:03 AM, Ross Burton wrote:

> 
> On 1 Sep 2023, at 11:03, Alexandre Belloni via lists.openembedded.org
> <alexandre.belloni=bootlin.com@lists.openembedded.org> wrote:
> 
>> 
>> Hello,
>> 
>> This fails on the autobuilders:
>> 
>> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/3449/steps/12/logs/stdio
>> 
>> 
>> ERROR: Nothing RPROVIDES 'distcc' (but
>> /home/pokybuild/yocto-worker/reproducible/build/meta/recipes-core/packagegroups/packagegroup-self-hosted.bb,
>> /home/pokybuild/yocto-worker/reproducible/build/meta/recipes-devtools/devel-config/distcc-config.bb
>> RDEPENDS on or otherwise requires it)
>> distcc was skipped: Recipe distcc, package distcc-server: system groupname
>> "nogroup" does not have a static ID defined. Add nogroup to one of these
>> files:
>> /home/pokybuild/yocto-worker/reproducible/build/build-st/meta-selftest/files/static-group
>> 
> 
> The same problem would hit the ppp-dialin but that recipe doesn’t get
> built in the AB in an environment that has static IPs.
> 
> Ross

I'm seeing the the warnings being generated in a multi-config Yocto build environment. Is there another way to address and fix the warnings I am having with the distcc and ppp-dialin recipes (possibly during parsing) even if they aren't being built in the AB with static IPs?
Richard Purdie Sept. 27, 2023, 2:01 p.m. UTC | #4
On Wed, 2023-09-27 at 06:07 -0700, JD Schroeder wrote:
> On Tue, Sep 12, 2023 at 06:03 AM, Ross Burton wrote:
> > On 1 Sep 2023, at 11:03, Alexandre Belloni via
> > lists.openembedded.org
> > <alexandre.belloni=bootlin.com@lists.openembedded.org> wrote:
> > > 
> > > Hello,
> > > 
> > > This fails on the autobuilders:
> > > 
> > > https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/3449/steps/12/logs/stdio
> > > 
> > > ERROR: Nothing RPROVIDES 'distcc' (but /home/pokybuild/yocto-
> > > worker/reproducible/build/meta/recipes-
> > > core/packagegroups/packagegroup-self-hosted.bb,
> > > /home/pokybuild/yocto-worker/reproducible/build/meta/recipes-
> > > devtools/devel-config/distcc-config.bb RDEPENDS on or otherwise
> > > requires it)
> > > distcc was skipped: Recipe distcc, package distcc-server: system
> > > groupname "nogroup" does not have a static ID defined. Add
> > > nogroup to one of these files: /home/pokybuild/yocto-
> > > worker/reproducible/build/build-st/meta-selftest/files/static-
> > > group
> > The same problem would hit the ppp-dialin but that recipe doesn’t
> > get built in the AB in an environment that has static IPs.
> > 
> > Ross
> I'm seeing the the warnings being generated in a multi-config Yocto
> build environment. Is there another way to address and fix the
> warnings I am having with the distcc and ppp-dialin recipes (possibly
> during parsing) even if they aren't being built in the AB with static
> IPs?

It might help if you could describe how to reproduce the problem you're
seeing?

"nogroup" should already exist in the underlying base-passwd file so we
really need to understand why that isn't working. The patch appears
just to mask the real problem.

Cheers,

Richard
JD Schroeder Oct. 26, 2023, 1:50 p.m. UTC | #5
On Wed, Sep 27, 2023 at 09:01 AM, Richard Purdie wrote:

> 
> On Wed, 2023-09-27 at 06:07 -0700, JD Schroeder wrote:
> 
>> On Tue, Sep 12, 2023 at 06:03 AM, Ross Burton wrote:
>> 
>>> On 1 Sep 2023, at 11:03, Alexandre Belloni via
>>> lists.openembedded.org
>>> <alexandre.belloni=bootlin.com@lists.openembedded.org> wrote:
>>> 
>>>> 
>>>> Hello,
>>>> 
>>>> This fails on the autobuilders:
>>>> 
>>>> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/3449/steps/12/logs/stdio
>>>> 
>>>> 
>>>> ERROR: Nothing RPROVIDES 'distcc' (but /home/pokybuild/yocto-
>>>> worker/reproducible/build/meta/recipes-
>>>> core/packagegroups/packagegroup-self-hosted.bb,
>>>> /home/pokybuild/yocto-worker/reproducible/build/meta/recipes-
>>>> devtools/devel-config/distcc-config.bb RDEPENDS on or otherwise
>>>> requires it)
>>>> distcc was skipped: Recipe distcc, package distcc-server: system
>>>> groupname "nogroup" does not have a static ID defined. Add
>>>> nogroup to one of these files: /home/pokybuild/yocto-
>>>> worker/reproducible/build/build-st/meta-selftest/files/static-
>>>> group
>>> 
>>> The same problem would hit the ppp-dialin but that recipe doesn’t
>>> get built in the AB in an environment that has static IPs.
>>> 
>>> Ross
>> 
>> I'm seeing the the warnings being generated in a multi-config Yocto
>> build environment. Is there another way to address and fix the
>> warnings I am having with the distcc and ppp-dialin recipes (possibly
>> during parsing) even if they aren't being built in the AB with static
>> IPs?
> 
> It might help if you could describe how to reproduce the problem you're
> seeing?
> 
> "nogroup" should already exist in the underlying base-passwd file so we
> really need to understand why that isn't working. The patch appears
> just to mask the real problem.
> 
> Cheers,
> 
> Richard

Sorry, it has taken a while for me to get back to this. I'm still seeing these warnings:

WARNING: yocto-4.0/poky/meta/recipes-devtools/distcc/distcc_3.4.bb: distcc: Changing groupname nogroup's gid from (1018) to (65534), verify configuration files!

WARNING: yocto-4.0/poky/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb: ppp-dialin: Changing groupname nogroup's gid from (1019) to (65534), verify configuration files!

The "nogroup" *does* exist in base-passed in group.master with "nogroup:*:65534:"

So it appears that something is originally setting the nogroup's gid to 1018 as the distcc recipe is parsed and later it gets changed to 65534 which causes the warning.

My patch fixes the warning and probably is not addressing the underlying problem. If someone has a patch they think addresses the underlying problem (clearing up the warning at the same time), I would be more than happy to test it for them in my environment and see if it fixes the warning.

To reiterate this is a nuisance warning fix and not a fundamental issue I'm seeing with my group ids. Addressing the warning in my build environment helps other new warnings that are introduced to be addressed and not ignored.

Thanks,

JD
diff mbox series

Patch

diff --git a/meta/recipes-devtools/distcc/distcc_3.4.bb b/meta/recipes-devtools/distcc/distcc_3.4.bb
index 45fc7cde53..0c20f74d68 100644
--- a/meta/recipes-devtools/distcc/distcc_3.4.bb
+++ b/meta/recipes-devtools/distcc/distcc_3.4.bb
@@ -33,6 +33,7 @@  EXTRA_OECONF += "--disable-Werror PYTHON='' --disable-pump-mode"
 PACKAGE_BEFORE_PN = "${PN}-distmon-gnome ${PN}-server"
 
 USERADD_PACKAGES = "${PN}-server"
+GROUPADD_PARAM:${PN}-server = "--system nogroup"
 USERADD_PARAM:${PN}-server = "--system \
                        --home /dev/null \
                        --no-create-home \