diff mbox series

[meta-python,v5] python3-piccata: piccata - a simple CoAP toolkit added

Message ID 1bda00e8-dd34-743e-b875-a9cf1e9dc739@3mdeb.com
State New
Headers show
Series [meta-python,v5] python3-piccata: piccata - a simple CoAP toolkit added | expand

Commit Message

Daniil Klimuk Aug. 30, 2023, 7:32 a.m. UTC
python3-piccata: piccata - a simple CoAP toolkit added

piccata is a simple CoAP (RFC7252) toolkit compatible with Python 2.7.

The toolkit provides basic building blocks for using CoAP in an
application. piccata handles messaging between endpoints
(retransmission, deduplication) and request/response matching.

Handling and matching resources, blockwise transfers, etc. is left to
the application but functions to faciliate this are provided.

piccata uses a transport abstraction to faciliate using the toolkit for
communication over different link types. Transport for a UDP socket is
provided.

Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>


+RDEPENDS:${PN} += "python3-core python3-datetime python3-io 
python3-logging python3-math"

Comments

Khem Raj Aug. 30, 2023, 7:33 a.m. UTC | #1
On Wed, Aug 30, 2023 at 12:32 AM Danik <daniil.klimuk@3mdeb.com> wrote:
>
> python3-piccata: piccata - a simple CoAP toolkit added
>
> piccata is a simple CoAP (RFC7252) toolkit compatible with Python 2.7.
>
> The toolkit provides basic building blocks for using CoAP in an
> application. piccata handles messaging between endpoints
> (retransmission, deduplication) and request/response matching.
>
> Handling and matching resources, blockwise transfers, etc. is left to
> the application but functions to faciliate this are provided.
>
> piccata uses a transport abstraction to faciliate using the toolkit for
> communication over different link types. Transport for a UDP socket is
> provided.
>
> Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>
>
>
> diff --git
> a/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
> b/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
> new file mode 100644
> index 000000000000..b625a038298f
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
> @@ -0,0 +1,14 @@
> +SUMMARY = "Python CoAP Toolkit"
> +HOMEPAGE = "https://github.com/NordicSemiconductor/piccata"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=e664eb75e2791c2e505e6e1c274e6d4f"
> +
> +SRCREV = "218d310e3d840715b1c8e67cefd5b6d71a2d7a1a"
> +PV = "2.0.3"

this is redundant

> +SRC_URI =
> "git://github.com/NordicSemiconductor/piccata.git;protocol=http;branch=master"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit setuptools3
> +
> +RDEPENDS:${PN} += "python3-core python3-datetime python3-io
> python3-logging python3-math"
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104654): https://lists.openembedded.org/g/openembedded-devel/message/104654
> Mute This Topic: https://lists.openembedded.org/mt/101047967/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git 
a/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb 
b/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
new file mode 100644
index 000000000000..b625a038298f
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "Python CoAP Toolkit"
+HOMEPAGE = "https://github.com/NordicSemiconductor/piccata"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e664eb75e2791c2e505e6e1c274e6d4f"
+
+SRCREV = "218d310e3d840715b1c8e67cefd5b6d71a2d7a1a"
+PV = "2.0.3"
+SRC_URI = 
"git://github.com/NordicSemiconductor/piccata.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+