diff mbox series

[meta-networking,kirkstone] spice-protocol: fix populate_sdk error when spice is installed

Message ID 20230828070502.2522488-1-Qi.Chen@windriver.com
State Under Review
Headers show
Series [meta-networking,kirkstone] spice-protocol: fix populate_sdk error when spice is installed | expand

Commit Message

ChenQi Aug. 28, 2023, 7:05 a.m. UTC
From: Chen Qi <Qi.Chen@windriver.com>

spice depends on spice-protocol, when IMAGE_INSTALL contains spice,
do_populate_sdk fails with the following error:

  Error:
  Problem: package libspice-server-dev-0.14.2+git0+7cbd70b931_4fc4c2db36-r0.core2_64 requires spice-protocol-dev, but none of the providers can be installed
  - conflicting requests
  - nothing provides spice-protocol = 0.14.4-r0 needed by spice-protocol-dev-0.14.4-r0.core2_64
  (try to add '--skip-broken' to skip uninstallable packages)

For spice-protocol, it's a development package and all things are in
the dev package, so set ALLOW_EMPTY to fix the above error.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Khem Raj Aug. 28, 2023, 5:04 p.m. UTC | #1
I think this applies to master too can you confirm.

On Mon, Aug 28, 2023 at 12:05 AM Chen Qi via lists.openembedded.org
<Qi.Chen=windriver.com@lists.openembedded.org> wrote:
>
> From: Chen Qi <Qi.Chen@windriver.com>
>
> spice depends on spice-protocol, when IMAGE_INSTALL contains spice,
> do_populate_sdk fails with the following error:
>
>   Error:
>   Problem: package libspice-server-dev-0.14.2+git0+7cbd70b931_4fc4c2db36-r0.core2_64 requires spice-protocol-dev, but none of the providers can be installed
>   - conflicting requests
>   - nothing provides spice-protocol = 0.14.4-r0 needed by spice-protocol-dev-0.14.4-r0.core2_64
>   (try to add '--skip-broken' to skip uninstallable packages)
>
> For spice-protocol, it's a development package and all things are in
> the dev package, so set ALLOW_EMPTY to fix the above error.
>
> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
> ---
>  meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb b/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
> index 9ce019ed86..3c8458baac 100644
> --- a/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
> +++ b/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
> @@ -16,4 +16,6 @@ S = "${WORKDIR}/git"
>
>  inherit meson pkgconfig
>
> +ALLOW_EMPTY:${PN} = "1"
> +
>  BBCLASSEXTEND = "native nativesdk"
> --
> 2.40.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104631): https://lists.openembedded.org/g/openembedded-devel/message/104631
> Mute This Topic: https://lists.openembedded.org/mt/101005385/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
ChenQi Aug. 30, 2023, 9:22 a.m. UTC | #2
On 8/29/23 01:04, Khem Raj wrote:
> I think this applies to master too can you confirm.

I just saw this message, and I then found you've helped merged this patch.

Thanks.

Regards,

Qi

>
> On Mon, Aug 28, 2023 at 12:05 AM Chen Qi via lists.openembedded.org
> <Qi.Chen=windriver.com@lists.openembedded.org> wrote:
>> From: Chen Qi <Qi.Chen@windriver.com>
>>
>> spice depends on spice-protocol, when IMAGE_INSTALL contains spice,
>> do_populate_sdk fails with the following error:
>>
>>    Error:
>>    Problem: package libspice-server-dev-0.14.2+git0+7cbd70b931_4fc4c2db36-r0.core2_64 requires spice-protocol-dev, but none of the providers can be installed
>>    - conflicting requests
>>    - nothing provides spice-protocol = 0.14.4-r0 needed by spice-protocol-dev-0.14.4-r0.core2_64
>>    (try to add '--skip-broken' to skip uninstallable packages)
>>
>> For spice-protocol, it's a development package and all things are in
>> the dev package, so set ALLOW_EMPTY to fix the above error.
>>
>> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
>> ---
>>   meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb | 2 ++
>>   1 file changed, 2 insertions(+)
>>
>> diff --git a/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb b/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
>> index 9ce019ed86..3c8458baac 100644
>> --- a/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
>> +++ b/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
>> @@ -16,4 +16,6 @@ S = "${WORKDIR}/git"
>>
>>   inherit meson pkgconfig
>>
>> +ALLOW_EMPTY:${PN} = "1"
>> +
>>   BBCLASSEXTEND = "native nativesdk"
>> --
>> 2.40.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#104631): https://lists.openembedded.org/g/openembedded-devel/message/104631
>> Mute This Topic: https://lists.openembedded.org/mt/101005385/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb b/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
index 9ce019ed86..3c8458baac 100644
--- a/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
+++ b/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
@@ -16,4 +16,6 @@  S = "${WORKDIR}/git"
 
 inherit meson pkgconfig
 
+ALLOW_EMPTY:${PN} = "1"
+
 BBCLASSEXTEND = "native nativesdk"