Patchwork [Consolidated,Pull,06/22] gnupg: add libusb to DEPENDS

login
register
mail settings
Submitter Elizabeth Flanagan
Date June 7, 2012, 11:36 p.m.
Message ID <e87b2862f0891a6f8ec214a362a018306a63d6ba.1339111944.git.elizabeth.flanagan@intel.com>
Download mbox | patch
Permalink /patch/29449/
State New
Headers show

Comments

Elizabeth Flanagan - June 7, 2012, 11:36 p.m.
From: Tom Zanussi <tom.zanussi@intel.com>

gnupg apparently depends on libusb:

| error: Failed dependencies:
| 	 libusb-0.1-4 >= 0.1.3 is needed by gnupg-2.0.18-r1.core2

So add libusb to gnupg DEPENDS.

Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Signed-off-by: Elizabeth Flanagan <elizabeth.flanagan@intel.com>
---
 meta/recipes-support/gnupg/gnupg_2.0.19.bb |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-support/gnupg/gnupg_2.0.19.bb b/meta/recipes-support/gnupg/gnupg_2.0.19.bb
index 1d19fe3..9a0f160 100644
--- a/meta/recipes-support/gnupg/gnupg_2.0.19.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.0.19.bb
@@ -4,8 +4,8 @@  LICENSE = "GPLv3 & LGPLv3"
 LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
                     file://COPYING.LIB;md5=6a6a8e020838b23406c81b19c1d46df6"
 
-DEPENDS = "pth libassuan libksba zlib bzip2 readline libgcrypt"
-PR = "r0"
+DEPENDS = "pth libassuan libksba zlib bzip2 readline libgcrypt libusb"
+PR = "r1"
 
 inherit autotools gettext