diff mbox series

[5/5] perf: disable perl support

Message ID 20230822170018.315470-5-ross.burton@arm.com
State Accepted, archived
Commit 55463c1898c220b79b77da95b2d0dd9bdc1628a2
Headers show
Series [1/5] perf: enable verbose feature detection | expand

Commit Message

Ross Burton Aug. 22, 2023, 5 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

The perf support was broken and if enabled results in non-reproducible
binaries, so disable it for now.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-kernel/perf/perf.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Tim Orling Aug. 23, 2023, 2:50 a.m. UTC | #1
On Tue, Aug 22, 2023 at 10:00 AM Ross Burton <ross.burton@arm.com> wrote:

> From: Ross Burton <ross.burton@arm.com>
>
> The perf support was broken and if enabled results in non-reproducible
> binaries, so disable it for now.


Excellent fallback. Bad that Perl support is broken, but excellent to have
isolated it.


>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-kernel/perf/perf.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/
> perf.bb
> index f89ab20ca41..e22a1bebb26 100644
> --- a/meta/recipes-kernel/perf/perf.bb
> +++ b/meta/recipes-kernel/perf/perf.bb
> @@ -11,7 +11,7 @@ LICENSE = "GPL-2.0-only"
>
>  PR = "r9"
>
> -PACKAGECONFIG ??= "perl python tui libunwind libtraceevent"
> +PACKAGECONFIG ??= "python tui libunwind libtraceevent"
>  PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
>  PACKAGECONFIG[perl] = ",NO_LIBPERL=1,perl"
>  PACKAGECONFIG[python] = ",NO_LIBPYTHON=1,python3
> python3-setuptools-native"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#186517):
> https://lists.openembedded.org/g/openembedded-core/message/186517
> Mute This Topic: https://lists.openembedded.org/mt/100898291/924729
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index f89ab20ca41..e22a1bebb26 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -11,7 +11,7 @@  LICENSE = "GPL-2.0-only"
 
 PR = "r9"
 
-PACKAGECONFIG ??= "perl python tui libunwind libtraceevent"
+PACKAGECONFIG ??= "python tui libunwind libtraceevent"
 PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
 PACKAGECONFIG[perl] = ",NO_LIBPERL=1,perl"
 PACKAGECONFIG[python] = ",NO_LIBPYTHON=1,python3 python3-setuptools-native"