Patchwork [bitbake-devel,5/5] Hob: fixed the index issue when set actived item for base image combo

login
register
mail settings
Submitter An, LimingX L
Date June 4, 2012, 10:52 a.m.
Message ID <926f93eacaaef0c0ae44d617945ff0064999d29f.1338806537.git.limingx.l.an@intel.com>
Download mbox | patch
Permalink /patch/29189/
State New
Headers show

Comments

An, LimingX L - June 4, 2012, 10:52 a.m.
The combo item index dosn't be increased as the insert a dummy item, when
execute the upadate base image combo operation.

[YOCTO #2500]

Signed-off-by: Liming An <limingx.l.an@intel.com>
---
 bitbake/lib/bb/ui/crumbs/imageconfigurationpage.py |    3 +--
 1 files changed, 1 insertions(+), 2 deletions(-)

Patch

diff --git a/bitbake/lib/bb/ui/crumbs/imageconfigurationpage.py b/bitbake/lib/bb/ui/crumbs/imageconfigurationpage.py
index b5f0a5a..80332fe 100644
--- a/bitbake/lib/bb/ui/crumbs/imageconfigurationpage.py
+++ b/bitbake/lib/bb/ui/crumbs/imageconfigurationpage.py
@@ -364,7 +364,7 @@  class ImageConfigurationPage (HobPage):
         filter = {RecipeListModel.COL_TYPE : ['image']}
         image_model = recipe_model.tree_model(filter)
         active = 0
-        cnt = 0
+        cnt = 1
 
         white_pattern = []
         if self.builder.parameters.image_white_pattern:
@@ -415,7 +415,6 @@  class ImageConfigurationPage (HobPage):
         if selected_image == self.builder.recipe_model.__custom_image__:
             active = cnt
 
-        self.image_combo.set_active(0)
         self.image_combo.set_active(active)
 
         if active != 0: