diff mbox series

[meta-python] python3-schedule: add recipe

Message ID 20230818114156.367538-1-roger@norberthealth.com
State Under Review
Headers show
Series [meta-python] python3-schedule: add recipe | expand

Commit Message

Roger Knecht Aug. 18, 2023, 11:41 a.m. UTC
Add a recipe for python schedule library.

Signed-off-by: Roger Knecht <roger@norberthealth.com>
---
 .../recipes-devtools/python/python3-schedule_1.2.0.bb  | 10 ++++++++++
 1 file changed, 10 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-schedule_1.2.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-schedule_1.2.0.bb b/meta-python/recipes-devtools/python/python3-schedule_1.2.0.bb
new file mode 100644
index 000000000..98b7690e1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-schedule_1.2.0.bb
@@ -0,0 +1,10 @@ 
+SUMMARY = "Job scheduling for humans"
+HOMEPAGE = "https://github.com/dbader/schedule"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6400f153491d45ea3459761627ca24b2"
+
+SRC_URI[sha256sum] = "b4ad697aafba7184c9eb6a1e2ebc41f781547242acde8ceae9a0a25b04c0922d"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "${PYTHON_PN}-datetime ${PYTHON_PN}-logging ${PYTHON_PN}-math"