diff mbox series

[meta-python] python3-oauth2client_4.1.2.bb: recipe added

Message ID 20230818112416.3669866-1-ewa.kujawska@3mdeb.com
State Under Review
Headers show
Series [meta-python] python3-oauth2client_4.1.2.bb: recipe added | expand

Commit Message

Ewa Kujawska Aug. 18, 2023, 11:24 a.m. UTC
Signed-off-by: Ewa Kujawska <ewa.kujawska@3mdeb.com>
---
 .../python3-oauth2client_4.1.2.bb             | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python3_oauth2client/python3-oauth2client_4.1.2.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python3_oauth2client/python3-oauth2client_4.1.2.bb b/meta-python/recipes-devtools/python3_oauth2client/python3-oauth2client_4.1.2.bb
new file mode 100644
index 000000000000..0301763030e0
--- /dev/null
+++ b/meta-python/recipes-devtools/python3_oauth2client/python3-oauth2client_4.1.2.bb
@@ -0,0 +1,19 @@ 
+DESCRIPTION = "OAuth 2.0 client library"
+
+HOMEPAGE = "http://github.com/google/oauth2client/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=038e1390e94fe637991fa5569daa62bc"
+
+inherit pypi
+
+SRC_URI[sha256sum] = "bd3062c06f8b10c6ef7a890b22c2740e5f87d61b6e1f4b1c90d069cdfc9dadb5"
+
+RDEPENDS:${PN} += " \
+        ${PYTHON_PN}-httplib2 \
+        ${PYTHON_PN}-pyasn1 \
+        ${PYTHON_PN}-pyasn1-modules \
+        ${PYTHON_PN}-rsa \
+        ${PYTHON_PN}-six \
+        "
+
+inherit setuptools3