diff mbox series

mdadm: disable strace on rv32 arch

Message ID 20230818105008.16113-1-dmitry.baryshkov@linaro.org
State Accepted, archived
Commit 9eca859f3bad9a881162f514d6147be5fd1351d9
Headers show
Series mdadm: disable strace on rv32 arch | expand

Commit Message

Dmitry Baryshkov Aug. 18, 2023, 10:50 a.m. UTC
strace program is not yet ported to RiscV 32 arch. Disable corresponding
dependency and test to remove dependency on the non-existing package,
which otherwise breaks building of core images:

ERROR: Nothing RPROVIDES 'strace' (but /oe/poky/meta/recipes-extended/mdadm/mdadm_4.2.bb RDEPENDS on or otherwise requires it)
strace was skipped: incompatible with host riscv32-poky-linux (not in COMPATIBLE_HOST)
NOTE: Runtime target 'strace' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['strace']
NOTE: Runtime target 'mdadm' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['mdadm', 'strace']
NOTE: Runtime target 'matchbox-terminal' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']
ERROR: Required build target 'core-image-weston' has no buildable providers.
Missing or unbuildable dependency chain was: ['core-image-weston', 'matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']

Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
---
 .../mdadm/files/broken-strace-rv32.patch               | 10 ++++++++++
 meta/recipes-extended/mdadm/mdadm_4.2.bb               |  4 ++++
 2 files changed, 14 insertions(+)
 create mode 100644 meta/recipes-extended/mdadm/files/broken-strace-rv32.patch

Comments

Richard Purdie Aug. 18, 2023, 10:56 a.m. UTC | #1
On Fri, 2023-08-18 at 13:50 +0300, Dmitry Baryshkov wrote:
> strace program is not yet ported to RiscV 32 arch. Disable corresponding
> dependency and test to remove dependency on the non-existing package,
> which otherwise breaks building of core images:
> 
> ERROR: Nothing RPROVIDES 'strace' (but /oe/poky/meta/recipes-extended/mdadm/mdadm_4.2.bb RDEPENDS on or otherwise requires it)
> strace was skipped: incompatible with host riscv32-poky-linux (not in COMPATIBLE_HOST)
> NOTE: Runtime target 'strace' is unbuildable, removing...
> Missing or unbuildable dependency chain was: ['strace']
> NOTE: Runtime target 'mdadm' is unbuildable, removing...
> Missing or unbuildable dependency chain was: ['mdadm', 'strace']
> NOTE: Runtime target 'matchbox-terminal' is unbuildable, removing...
> Missing or unbuildable dependency chain was: ['matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']
> ERROR: Required build target 'core-image-weston' has no buildable providers.
> Missing or unbuildable dependency chain was: ['core-image-weston', 'matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']
> 
> Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
> ---
>  .../mdadm/files/broken-strace-rv32.patch               | 10 ++++++++++
>  meta/recipes-extended/mdadm/mdadm_4.2.bb               |  4 ++++
>  2 files changed, 14 insertions(+)
>  create mode 100644 meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> 
> diff --git a/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch b/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> new file mode 100644
> index 000000000000..a58495008605
> --- /dev/null
> +++ b/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> @@ -0,0 +1,10 @@
> +Index: mdadm-4.2/tests/07revert-inplace.broken
> +===================================================================
> +--- /dev/null
> ++++ mdadm-4.2/tests/07revert-inplace.broken
> +@@ -0,0 +1,5 @@
> ++fails on RiscV32
> ++
> ++Fails with the following message:
> ++    strace -o /tmp/str ./mdadm -A /dev/md0 --update=revert-reshape /dev/<...>
> ++    tests/07revert-inplace: line 40: strace: command not found
> diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> index fa50325f1f71..3085222061f0 100644
> --- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
> +++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> @@ -126,3 +126,7 @@ RRECOMMENDS:${PN}-ptest += " \
>  "
>  
>  FILES:${PN} += "${systemd_unitdir}/*"
> +
> +# strace is not yet ported to rv32
> +SRC_URI:riscv32 += "broken-strace-rv32.patch"
> +RDEPENDS:${PN}-ptest:remove:riscv32 = "strace"

The patch has no Upstream-Status: entry which makes me wonder how it
was tested as this should have given warnings.

I also suspect it may be easier to just write a
do_install:append:riscv32 that creates the file instead of a patch?

Cheers,

Richard
Alexander Kanavin Aug. 18, 2023, 11 a.m. UTC | #2
Upstream however should be made aware of the issue, so there should be
either a link to the patch submission, or a link to an upstream ticket
as well.

Alex

On Fri, 18 Aug 2023 at 12:56, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
>
> On Fri, 2023-08-18 at 13:50 +0300, Dmitry Baryshkov wrote:
> > strace program is not yet ported to RiscV 32 arch. Disable corresponding
> > dependency and test to remove dependency on the non-existing package,
> > which otherwise breaks building of core images:
> >
> > ERROR: Nothing RPROVIDES 'strace' (but /oe/poky/meta/recipes-extended/mdadm/mdadm_4.2.bb RDEPENDS on or otherwise requires it)
> > strace was skipped: incompatible with host riscv32-poky-linux (not in COMPATIBLE_HOST)
> > NOTE: Runtime target 'strace' is unbuildable, removing...
> > Missing or unbuildable dependency chain was: ['strace']
> > NOTE: Runtime target 'mdadm' is unbuildable, removing...
> > Missing or unbuildable dependency chain was: ['mdadm', 'strace']
> > NOTE: Runtime target 'matchbox-terminal' is unbuildable, removing...
> > Missing or unbuildable dependency chain was: ['matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']
> > ERROR: Required build target 'core-image-weston' has no buildable providers.
> > Missing or unbuildable dependency chain was: ['core-image-weston', 'matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']
> >
> > Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
> > ---
> >  .../mdadm/files/broken-strace-rv32.patch               | 10 ++++++++++
> >  meta/recipes-extended/mdadm/mdadm_4.2.bb               |  4 ++++
> >  2 files changed, 14 insertions(+)
> >  create mode 100644 meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> >
> > diff --git a/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch b/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> > new file mode 100644
> > index 000000000000..a58495008605
> > --- /dev/null
> > +++ b/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> > @@ -0,0 +1,10 @@
> > +Index: mdadm-4.2/tests/07revert-inplace.broken
> > +===================================================================
> > +--- /dev/null
> > ++++ mdadm-4.2/tests/07revert-inplace.broken
> > +@@ -0,0 +1,5 @@
> > ++fails on RiscV32
> > ++
> > ++Fails with the following message:
> > ++    strace -o /tmp/str ./mdadm -A /dev/md0 --update=revert-reshape /dev/<...>
> > ++    tests/07revert-inplace: line 40: strace: command not found
> > diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> > index fa50325f1f71..3085222061f0 100644
> > --- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
> > +++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> > @@ -126,3 +126,7 @@ RRECOMMENDS:${PN}-ptest += " \
> >  "
> >
> >  FILES:${PN} += "${systemd_unitdir}/*"
> > +
> > +# strace is not yet ported to rv32
> > +SRC_URI:riscv32 += "broken-strace-rv32.patch"
> > +RDEPENDS:${PN}-ptest:remove:riscv32 = "strace"
>
> The patch has no Upstream-Status: entry which makes me wonder how it
> was tested as this should have given warnings.
>
> I also suspect it may be easier to just write a
> do_install:append:riscv32 that creates the file instead of a patch?
>
> Cheers,
>
> Richard
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#186358): https://lists.openembedded.org/g/openembedded-core/message/186358
> Mute This Topic: https://lists.openembedded.org/mt/100817941/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Dmitry Baryshkov Aug. 18, 2023, 2:46 p.m. UTC | #3
On Fri, 18 Aug 2023 at 14:00, Alexander Kanavin <alex.kanavin@gmail.com> wrote:
>
> Upstream however should be made aware of the issue, so there should be
> either a link to the patch submission, or a link to an upstream ticket
> as well.

There is no issue tracker for mdadm. And granted all test.broken files
in OE's patchset I doubt that mdadm / linux-raid people are really
interested in these reports.

>
> Alex
>
> On Fri, 18 Aug 2023 at 12:56, Richard Purdie
> <richard.purdie@linuxfoundation.org> wrote:
> >
> > On Fri, 2023-08-18 at 13:50 +0300, Dmitry Baryshkov wrote:
> > > strace program is not yet ported to RiscV 32 arch. Disable corresponding
> > > dependency and test to remove dependency on the non-existing package,
> > > which otherwise breaks building of core images:
> > >
> > > ERROR: Nothing RPROVIDES 'strace' (but /oe/poky/meta/recipes-extended/mdadm/mdadm_4.2.bb RDEPENDS on or otherwise requires it)
> > > strace was skipped: incompatible with host riscv32-poky-linux (not in COMPATIBLE_HOST)
> > > NOTE: Runtime target 'strace' is unbuildable, removing...
> > > Missing or unbuildable dependency chain was: ['strace']
> > > NOTE: Runtime target 'mdadm' is unbuildable, removing...
> > > Missing or unbuildable dependency chain was: ['mdadm', 'strace']
> > > NOTE: Runtime target 'matchbox-terminal' is unbuildable, removing...
> > > Missing or unbuildable dependency chain was: ['matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']
> > > ERROR: Required build target 'core-image-weston' has no buildable providers.
> > > Missing or unbuildable dependency chain was: ['core-image-weston', 'matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']
> > >
> > > Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
> > > ---
> > >  .../mdadm/files/broken-strace-rv32.patch               | 10 ++++++++++
> > >  meta/recipes-extended/mdadm/mdadm_4.2.bb               |  4 ++++
> > >  2 files changed, 14 insertions(+)
> > >  create mode 100644 meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> > >
> > > diff --git a/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch b/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> > > new file mode 100644
> > > index 000000000000..a58495008605
> > > --- /dev/null
> > > +++ b/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
> > > @@ -0,0 +1,10 @@
> > > +Index: mdadm-4.2/tests/07revert-inplace.broken
> > > +===================================================================
> > > +--- /dev/null
> > > ++++ mdadm-4.2/tests/07revert-inplace.broken
> > > +@@ -0,0 +1,5 @@
> > > ++fails on RiscV32
> > > ++
> > > ++Fails with the following message:
> > > ++    strace -o /tmp/str ./mdadm -A /dev/md0 --update=revert-reshape /dev/<...>
> > > ++    tests/07revert-inplace: line 40: strace: command not found
> > > diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> > > index fa50325f1f71..3085222061f0 100644
> > > --- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
> > > +++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> > > @@ -126,3 +126,7 @@ RRECOMMENDS:${PN}-ptest += " \
> > >  "
> > >
> > >  FILES:${PN} += "${systemd_unitdir}/*"
> > > +
> > > +# strace is not yet ported to rv32
> > > +SRC_URI:riscv32 += "broken-strace-rv32.patch"
> > > +RDEPENDS:${PN}-ptest:remove:riscv32 = "strace"
> >
> > The patch has no Upstream-Status: entry which makes me wonder how it
> > was tested as this should have given warnings.
> >
> > I also suspect it may be easier to just write a
> > do_install:append:riscv32 that creates the file instead of a patch?
> >
> > Cheers,
> >
> > Richard
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#186358): https://lists.openembedded.org/g/openembedded-core/message/186358
> > Mute This Topic: https://lists.openembedded.org/mt/100817941/1686489
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
diff mbox series

Patch

diff --git a/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch b/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
new file mode 100644
index 000000000000..a58495008605
--- /dev/null
+++ b/meta/recipes-extended/mdadm/files/broken-strace-rv32.patch
@@ -0,0 +1,10 @@ 
+Index: mdadm-4.2/tests/07revert-inplace.broken
+===================================================================
+--- /dev/null
++++ mdadm-4.2/tests/07revert-inplace.broken
+@@ -0,0 +1,5 @@
++fails on RiscV32
++
++Fails with the following message:
++    strace -o /tmp/str ./mdadm -A /dev/md0 --update=revert-reshape /dev/<...>
++    tests/07revert-inplace: line 40: strace: command not found
diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
index fa50325f1f71..3085222061f0 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
@@ -126,3 +126,7 @@  RRECOMMENDS:${PN}-ptest += " \
 "
 
 FILES:${PN} += "${systemd_unitdir}/*"
+
+# strace is not yet ported to rv32
+SRC_URI:riscv32 += "broken-strace-rv32.patch"
+RDEPENDS:${PN}-ptest:remove:riscv32 = "strace"