diff mbox series

[meta-python,v2] python3-libusb1_1.7.1.bb: recipe added

Message ID 20230817124736.3524633-1-ewa.kujawska@3mdeb.com
State New
Headers show
Series [meta-python,v2] python3-libusb1_1.7.1.bb: recipe added | expand

Commit Message

Ewa Kujawska Aug. 17, 2023, 12:47 p.m. UTC
A pure-python wrapper for libusb-1.0 refers to a Python module or
package that provides an interface to interact with the libusb-1.0
library using Python code. libusb-1.0 is a cross-platform library
that allows applications to communicate with USB devices without
the need for platform-specific drivers. It provides a standardized
way to access USB devices from various operating systems.

Signed-off-by: Ewa Kujawska <ewa.kujawska@3mdeb.com>
---
 .../python/python3-libusb1_1.7.1.bb                 | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

Comments

Khem Raj Aug. 17, 2023, 3:11 p.m. UTC | #1
this does not apply on top of master or master-next, please rebase and
send again.

On Thu, Aug 17, 2023 at 5:47 AM Ewa Kujawska <ewa.kujawska@3mdeb.com> wrote:
>
> A pure-python wrapper for libusb-1.0 refers to a Python module or
> package that provides an interface to interact with the libusb-1.0
> library using Python code. libusb-1.0 is a cross-platform library
> that allows applications to communicate with USB devices without
> the need for platform-specific drivers. It provides a standardized
> way to access USB devices from various operating systems.
>
> Signed-off-by: Ewa Kujawska <ewa.kujawska@3mdeb.com>
> ---
>  .../python/python3-libusb1_1.7.1.bb                 | 13 +++++++------
>  1 file changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/meta-python/recipes-devtools/python/python3-libusb1_1.7.1.bb b/meta-python/recipes-devtools/python/python3-libusb1_1.7.1.bb
> index 476966c2178b..9f95e5595178 100644
> --- a/meta-python/recipes-devtools/python/python3-libusb1_1.7.1.bb
> +++ b/meta-python/recipes-devtools/python/python3-libusb1_1.7.1.bb
> @@ -1,15 +1,16 @@
>  SUMMARY = "Pure-python wrapper for libusb-1.0"
> +
>  HOMEPAGE = "http://github.com/vpelletier/python-libusb1"
> -AUTHOR = "Vincent Pelletier <plr.vincent@gmail.com>"
> -LICENSE = "LGPL-2.1"
> +LICENSE = "LGPL-2.1-only"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
>
> -SRC_URI = "https://files.pythonhosted.org/packages/80/bb/4ee9d760dd29499d877ee384f1d2bc6bb9923defd4c69843aef5e729972d/libusb1-1.7.1.tar.gz"
> -SRC_URI[md5sum] = "cb4073182fef4cee6ab9c6666b48d1a1"
> +SRC_URI = "https://files.pythonhosted.org/packages/80/bb/4ee9d760dd29499d877ee384f1d2bc6bb9923defd4c69843aef5e729972d/libusb1-${PV}.tar.gz"
>  SRC_URI[sha256sum] = "adf64a4f3f5c94643a1286f8153bcf4bc787c348b38934aacd7fe17fbeebc571"
>
> -S = "${WORKDIR}/libusb1-1.7.1"
> +PV = "1.7.1"
> +
> +S = "${WORKDIR}/libusb1-${PV}"
>
> -RDEPENDS_${PN} = "libusb1"
> +RDEPENDS:${PN} = "libusb1"
>
>  inherit setuptools3
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104463): https://lists.openembedded.org/g/openembedded-devel/message/104463
> Mute This Topic: https://lists.openembedded.org/mt/100799510/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-libusb1_1.7.1.bb b/meta-python/recipes-devtools/python/python3-libusb1_1.7.1.bb
index 476966c2178b..9f95e5595178 100644
--- a/meta-python/recipes-devtools/python/python3-libusb1_1.7.1.bb
+++ b/meta-python/recipes-devtools/python/python3-libusb1_1.7.1.bb
@@ -1,15 +1,16 @@ 
 SUMMARY = "Pure-python wrapper for libusb-1.0"
+
 HOMEPAGE = "http://github.com/vpelletier/python-libusb1"
-AUTHOR = "Vincent Pelletier <plr.vincent@gmail.com>"
-LICENSE = "LGPL-2.1"
+LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
-SRC_URI = "https://files.pythonhosted.org/packages/80/bb/4ee9d760dd29499d877ee384f1d2bc6bb9923defd4c69843aef5e729972d/libusb1-1.7.1.tar.gz"
-SRC_URI[md5sum] = "cb4073182fef4cee6ab9c6666b48d1a1"
+SRC_URI = "https://files.pythonhosted.org/packages/80/bb/4ee9d760dd29499d877ee384f1d2bc6bb9923defd4c69843aef5e729972d/libusb1-${PV}.tar.gz"
 SRC_URI[sha256sum] = "adf64a4f3f5c94643a1286f8153bcf4bc787c348b38934aacd7fe17fbeebc571"
 
-S = "${WORKDIR}/libusb1-1.7.1"
+PV = "1.7.1"
+
+S = "${WORKDIR}/libusb1-${PV}"
 
-RDEPENDS_${PN} = "libusb1"
+RDEPENDS:${PN} = "libusb1"
 
 inherit setuptools3