diff mbox series

[meta-python,v2] python3-gspread: interface for google spreadsheet

Message ID 23ea8ba5-7d80-44c9-86a3-c527bb935cf5@3mdeb.com
State New
Headers show
Series [meta-python,v2] python3-gspread: interface for google spreadsheet | expand

Commit Message

Daniil Klimuk Aug. 17, 2023, 7:25 a.m. UTC
python3-gspread: interface for google spreadsheet

Adds simple interface for working with Google Sheets.

Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>

+RDEPENDS:${PN} = "python3-requests"
+
+inherit python_poetry_core

Comments

Khem Raj Aug. 17, 2023, 3:50 p.m. UTC | #1
does not apply cleanly on master or master-next  please rebase and resend.

On Thu, Aug 17, 2023 at 12:25 AM Danik <daniil.klimuk@3mdeb.com> wrote:
>
> python3-gspread: interface for google spreadsheet
>
> Adds simple interface for working with Google Sheets.
>
> Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>
>
> diff --git
> a/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
> b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
> new file mode 100644
> index 000000000000..0c8fb648e701
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
> @@ -0,0 +1,15 @@
> +SUMMARY = "Google Spreadsheets Python API"
> +HOMEPAGE = "https://github.com/burnash/gspread"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM =
> "file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f"
> +
> +SRC_URI =
> "https://files.pythonhosted.org/packages/b4/4f/033ebf34778745061b67b104ef212ed5b05fa65a530f345f88c4355fdcc3/gspread-5.10.0.tar.gz"
> +SRC_URI[sha256sum] =
> "2b6bba6dc111580170346a9bcd1893e0e8c52f67a9e537caec7b7a1e27c14435"
> +
> +PV = "5.10.0"
> +
> +S = "${WORKDIR}/gspread-${PV}"
> +
> +RDEPENDS:${PN} = "python3-requests"
> +
> +inherit python_poetry_core
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104447): https://lists.openembedded.org/g/openembedded-devel/message/104447
> Mute This Topic: https://lists.openembedded.org/mt/100796205/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git 
a/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb 
b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
new file mode 100644
index 000000000000..0c8fb648e701
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Google Spreadsheets Python API"
+HOMEPAGE = "https://github.com/burnash/gspread"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = 
"file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f"
+
+SRC_URI = 
"https://files.pythonhosted.org/packages/b4/4f/033ebf34778745061b67b104ef212ed5b05fa65a530f345f88c4355fdcc3/gspread-5.10.0.tar.gz"
+SRC_URI[sha256sum] = 
"2b6bba6dc111580170346a9bcd1893e0e8c52f67a9e537caec7b7a1e27c14435"
+
+PV = "5.10.0"
+
+S = "${WORKDIR}/gspread-${PV}"
+