diff mbox series

[meta-oe] jemalloc: Unbolt clang workaroud

Message ID 20230815212057.264244-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] jemalloc: Unbolt clang workaroud | expand

Commit Message

Khem Raj Aug. 15, 2023, 9:20 p.m. UTC
This works well with clang 15+

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...imization-with-clang-for-aligned_all.patch | 33 -------------------
 .../jemalloc/jemalloc_5.3.0.bb                |  4 ---
 2 files changed, 37 deletions(-)
 delete mode 100644 meta-oe/recipes-devtools/jemalloc/files/0001-test-Disable-optimization-with-clang-for-aligned_all.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/jemalloc/files/0001-test-Disable-optimization-with-clang-for-aligned_all.patch b/meta-oe/recipes-devtools/jemalloc/files/0001-test-Disable-optimization-with-clang-for-aligned_all.patch
deleted file mode 100644
index 570202e800..0000000000
--- a/meta-oe/recipes-devtools/jemalloc/files/0001-test-Disable-optimization-with-clang-for-aligned_all.patch
+++ /dev/null
@@ -1,33 +0,0 @@ 
-From 3fe67deb9fcf0ae3c2ff31a9eccb6a0a9af33b9c Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 14 Jan 2022 09:47:03 -0800
-Subject: [PATCH] test: Disable optimization with clang for aligned_alloc.c
-
-Clang crashes when using glibc 2.35, it works ok with older glibc or
-musl, so its very specific problem. Its reported here
-
-https://github.com/llvm/llvm-project/issues/52765
-
-Until it is fixed, workaround the build failure
-
-Upstream-Status: Inappropriate [Workaround]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- test/integration/aligned_alloc.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/test/integration/aligned_alloc.c b/test/integration/aligned_alloc.c
-index 4375b172..6513bdd9 100644
---- a/test/integration/aligned_alloc.c
-+++ b/test/integration/aligned_alloc.c
-@@ -1,5 +1,7 @@
- #include "test/jemalloc_test.h"
- 
-+#pragma clang optimize off
-+
- #define MAXALIGN (((size_t)1) << 23)
- 
- /*
--- 
-2.34.1
-
diff --git a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
index 9ad83261ef..3d48bc012d 100644
--- a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
+++ b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
@@ -16,10 +16,6 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=ea061f8731d5e6a5761dfad951ef5f5f"
 SRC_URI = "git://github.com/jemalloc/jemalloc.git;branch=master;protocol=https \
            file://run-ptest \
            "
-
-# Workaround for https://github.com/llvm/llvm-project/issues/52765
-SRC_URI:append:libc-glibc:toolchain-clang = " file://0001-test-Disable-optimization-with-clang-for-aligned_all.patch "
-
 SRCREV = "54eaed1d8b56b1aa528be3bdd1877e59c56fa90c"
 
 S = "${WORKDIR}/git"