diff mbox series

[meta-arago,master/kirkstone] mstpd: Add FILES variable

Message ID 20230812131654.25185-1-reatmon@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,master/kirkstone] mstpd: Add FILES variable | expand

Commit Message

Ryan Eatmon Aug. 12, 2023, 1:16 p.m. UTC
Bring this recipe into compliance with the latest standards.  Add
missing FILES and update hardcoded /sbin path to $base_sbindir.

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
 meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

Comments

Denys Dmytriyenko Aug. 14, 2023, 6:10 p.m. UTC | #1
On Sat, Aug 12, 2023 at 08:16:54AM -0500, Ryan Eatmon via lists.yoctoproject.org wrote:
> Bring this recipe into compliance with the latest standards.  Add
> missing FILES and update hardcoded /sbin path to $base_sbindir.

Well, you don't have to touch FILES, as the defaults here seem to cover 
everything just fine. Plus, you are adding to the defaults, not replacing 
them, so that's a no-op.

Changing hardcoded /sbin to ${base_sbindir} is all you need here.


> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> ---
>  meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb | 10 +++++++++-
>  1 file changed, 9 insertions(+), 1 deletion(-)
> 
> diff --git a/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb b/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
> index a410f584..be75b1c5 100644
> --- a/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
> +++ b/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
> @@ -17,7 +17,15 @@ RDEPENDS:${PN} = "python3-core"
>  
>  inherit autotools
>  
> -EXTRA_OECONF = "--sbindir=/sbin"
> +EXTRA_OECONF = "--sbindir=${base_sbindir}"
> +
> +FILES:${PN} += " \
> +    ${base_sbindir}/mstp* \
> +    ${base_sbindir}/bridge-stp \
> +    ${libexecdir}/mstpctl-utils/* \
> +    ${sysconfdir}/bridge-stp.conf \
> +    ${sysconfdir}/bash_completion.d/mstpctl \
> +"

So, the defaults already have ${base_sbindir}/* ${libexecdir}/* and 
${sysconfdir} and will scoop up everything the recipe installs in those 
directories.

https://git.openembedded.org/openembedded-core/tree/meta/conf/bitbake.conf#n331


>  do_configure:prepend() {
>  	 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/utils/ifquery
> -- 
> 2.17.1
Ryan Eatmon Aug. 14, 2023, 6:32 p.m. UTC | #2
On 8/14/2023 1:10 PM, Denys Dmytriyenko wrote:
> On Sat, Aug 12, 2023 at 08:16:54AM -0500, Ryan Eatmon via lists.yoctoproject.org wrote:
>> Bring this recipe into compliance with the latest standards.  Add
>> missing FILES and update hardcoded /sbin path to $base_sbindir.
> 
> Well, you don't have to touch FILES, as the defaults here seem to cover
> everything just fine. Plus, you are adding to the defaults, not replacing
> them, so that's a no-op.
> 
> Changing hardcoded /sbin to ${base_sbindir} is all you need here.

That would explain why when I added /sbin/* to the FILES a bunch of 
other errors popped up!  I changed the default.  That was confusing me a 
bit.  I'll get this fixed for a v2.  Thanks!

> 
>> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
>> ---
>>   meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb | 10 +++++++++-
>>   1 file changed, 9 insertions(+), 1 deletion(-)
>>
>> diff --git a/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb b/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
>> index a410f584..be75b1c5 100644
>> --- a/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
>> +++ b/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
>> @@ -17,7 +17,15 @@ RDEPENDS:${PN} = "python3-core"
>>   
>>   inherit autotools
>>   
>> -EXTRA_OECONF = "--sbindir=/sbin"
>> +EXTRA_OECONF = "--sbindir=${base_sbindir}"
>> +
>> +FILES:${PN} += " \
>> +    ${base_sbindir}/mstp* \
>> +    ${base_sbindir}/bridge-stp \
>> +    ${libexecdir}/mstpctl-utils/* \
>> +    ${sysconfdir}/bridge-stp.conf \
>> +    ${sysconfdir}/bash_completion.d/mstpctl \
>> +"
> 
> So, the defaults already have ${base_sbindir}/* ${libexecdir}/* and
> ${sysconfdir} and will scoop up everything the recipe installs in those
> directories.
> 
> https://git.openembedded.org/openembedded-core/tree/meta/conf/bitbake.conf#n331
> 
> 
>>   do_configure:prepend() {
>>   	 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/utils/ifquery
>> -- 
>> 2.17.1
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb b/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
index a410f584..be75b1c5 100644
--- a/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
+++ b/meta-arago-extras/recipes-support/mstpctl/mstpd_git.bb
@@ -17,7 +17,15 @@  RDEPENDS:${PN} = "python3-core"
 
 inherit autotools
 
-EXTRA_OECONF = "--sbindir=/sbin"
+EXTRA_OECONF = "--sbindir=${base_sbindir}"
+
+FILES:${PN} += " \
+    ${base_sbindir}/mstp* \
+    ${base_sbindir}/bridge-stp \
+    ${libexecdir}/mstpctl-utils/* \
+    ${sysconfdir}/bridge-stp.conf \
+    ${sysconfdir}/bash_completion.d/mstpctl \
+"
 
 do_configure:prepend() {
 	 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/utils/ifquery