diff mbox series

arm-bsp/u-boot: corstone1000: detect the kernel size automatically

Message ID 20230811135651.1691251-1-abdellatif.elkhlifi@arm.com
State New
Headers show
Series arm-bsp/u-boot: corstone1000: detect the kernel size automatically | expand

Commit Message

Abdellatif El Khlifi Aug. 11, 2023, 1:56 p.m. UTC
From: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>

use filesize environment variable to read the size of the unzipped initramfs bundle

Signed-off-by: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>
---
 ...one1000-detect-inflated-kernel-size.patch} | 20 +++++++++----------
 .../recipes-bsp/u-boot/u-boot_%.bbappend      |  2 +-
 2 files changed, 11 insertions(+), 11 deletions(-)
 rename meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/{0033-Increase-the-unzipped-Kernel-size.patch => 0033-corstone1000-detect-inflated-kernel-size.patch} (63%)

Comments

Jon Mason Aug. 11, 2023, 11:20 p.m. UTC | #1
On Fri, 11 Aug 2023 14:56:51 +0100, abdellatif.elkhlifi@arm.com wrote:
> use filesize environment variable to read the size of the unzipped initramfs bundle
> 
> 

Applied, thanks!

[1/1] arm-bsp/u-boot: corstone1000: detect the kernel size automatically
      commit: ea9ca499c9cc16e579b2c3eb59c2947463a23ab7

Best regards,
diff mbox series

Patch

diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0033-Increase-the-unzipped-Kernel-size.patch b/meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0033-corstone1000-detect-inflated-kernel-size.patch
similarity index 63%
rename from meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0033-Increase-the-unzipped-Kernel-size.patch
rename to meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0033-corstone1000-detect-inflated-kernel-size.patch
index 63c42c70..9fd5b33b 100644
--- a/meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0033-Increase-the-unzipped-Kernel-size.patch
+++ b/meta-arm-bsp/recipes-bsp/u-boot/u-boot/corstone1000/0033-corstone1000-detect-inflated-kernel-size.patch
@@ -1,29 +1,29 @@ 
-From df23489adcba1cdcbcb4fefbed0896fc1f408700 Mon Sep 17 00:00:00 2001
-From: Emekcan Aras <emekcan.aras@arm.com>
-Date: Wed, 2 Aug 2023 17:07:05 +0100
-Subject: [PATCH] Increase the unzipped Kernel size
+From b57e05e95735b9b58e81b7a67f483b645c56811e Mon Sep 17 00:00:00 2001
+From: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>
+Date: Fri, 11 Aug 2023 10:41:19 +0100
+Subject: [PATCH] corstone1000: detect inflated kernel size
 
-Increases the unzipped kernel size for corstone1000.
+use filesize variable set by unzip command
 
 Upstream-Status: Pending [Not submitted to upstream yet]
-Signed-off-by: Emekcan Aras <emekcan.aras@arm.com>
+Signed-off-by: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>
 ---
  configs/corstone1000_defconfig | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/configs/corstone1000_defconfig b/configs/corstone1000_defconfig
-index a0af413de8..54a5bca354 100644
+index b6b1ccdd78..8a10bca069 100644
 --- a/configs/corstone1000_defconfig
 +++ b/configs/corstone1000_defconfig
-@@ -15,7 +15,7 @@ CONFIG_DISTRO_DEFAULTS=y
+@@ -17,7 +17,7 @@ CONFIG_FIT=y
  CONFIG_BOOTDELAY=3
  CONFIG_USE_BOOTARGS=y
  CONFIG_BOOTARGS="console=ttyAMA0 loglevel=9 ip=dhcp earlyprintk"
 -CONFIG_BOOTCOMMAND="echo Loading kernel from $kernel_addr to memory ... ; unzip $kernel_addr 0x90000000; loadm 0x90000000 $kernel_addr_r 0xf00000; usb start; usb reset; run distro_bootcmd; bootefi $kernel_addr_r $fdtcontroladdr;"
-+CONFIG_BOOTCOMMAND="echo Loading kernel from $kernel_addr to memory ... ; unzip $kernel_addr 0x90000000; loadm 0x90000000 $kernel_addr_r 0xfb0000; usb start; usb reset; run distro_bootcmd; bootefi $kernel_addr_r $fdtcontroladdr;"
++CONFIG_BOOTCOMMAND="echo Loading kernel from $kernel_addr to memory ... ; unzip $kernel_addr 0x90000000; loadm 0x90000000 $kernel_addr_r $filesize; usb start; usb reset; run distro_bootcmd; bootefi $kernel_addr_r $fdtcontroladdr;"
  CONFIG_CONSOLE_RECORD=y
  CONFIG_LOGLEVEL=7
  # CONFIG_DISPLAY_CPUINFO is not set
 -- 
-2.17.1
+2.25.1
 
diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
index 6c0d4904..389f236e 100644
--- a/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -50,7 +50,7 @@  SRC_URI:append:corstone1000 = " \
 	file://0030-corstone1000-boot-index-from-active.patch			  \
 	file://0031-corstone1000-enable-PSCI-reset.patch			  \
 	file://0032-Enable-EFI-set-get-time-services.patch			  \
-	file://0033-Increase-the-unzipped-Kernel-size.patch			  \
+	file://0033-corstone1000-detect-inflated-kernel-size.patch			  \
         "
 
 #