diff mbox series

[meta-oe] qad: Fix build with clang

Message ID 20230811070541.709014-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] qad: Fix build with clang | expand

Commit Message

Khem Raj Aug. 11, 2023, 7:05 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...Fix-warnings-found-by-clang-compiler.patch | 53 +++++++++++++++++++
 meta-oe/recipes-extended/qad/qad_git.bb       |  3 +-
 2 files changed, 55 insertions(+), 1 deletion(-)
 create mode 100644 meta-oe/recipes-extended/qad/qad/0001-Fix-warnings-found-by-clang-compiler.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/qad/qad/0001-Fix-warnings-found-by-clang-compiler.patch b/meta-oe/recipes-extended/qad/qad/0001-Fix-warnings-found-by-clang-compiler.patch
new file mode 100644
index 0000000000..7a9937d685
--- /dev/null
+++ b/meta-oe/recipes-extended/qad/qad/0001-Fix-warnings-found-by-clang-compiler.patch
@@ -0,0 +1,53 @@ 
+From 2e871d6d6d13955ff363ff756adfdd257e72e9e8 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 10 Aug 2023 23:58:43 -0700
+Subject: [PATCH] Fix warnings found by clang compiler
+
+Fix diagnostics found with -Wdeprecated-non-prototype using clang
+compiler
+
+e.g.
+| ../git/src/server.c:108:35: error: passing arguments to a function without a prototype is deprecated in all versions of C and is not supported in C2x [-Werror,-Wdeprecated-non-prototype]  |   108 |   if (backend->input_backend->move(x, y, event) < 0) {                                                                                                                              |       |                                   ^
+
+Upstream-Status: Submitted [https://gitlab.com/CodethinkLabs/qad/qad/-/merge_requests/33]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ include/backend.h                 | 8 ++++----
+ src/backends/input/input_common.h | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/include/backend.h b/include/backend.h
+index 8f4c7c1..4bfe510 100644
+--- a/include/backend.h
++++ b/include/backend.h
+@@ -41,10 +41,10 @@ typedef struct qad_screen_buffer_s {
+ } qad_screen_buffer_t;
+ 
+ typedef struct qad_backend_input_s {
+-  int (*move)();
+-  int (*button)();
+-  int (*touch)();
+-  int (*swipe)();
++  int (*move)(int, int, int);
++  int (*button)(int, int);
++  int (*touch)(int, int, int, int);
++  int (*swipe)(int, int, int, int, int, int);
+   void *data;
+ } qad_backend_input_t;
+ 
+diff --git a/src/backends/input/input_common.h b/src/backends/input/input_common.h
+index 8e099a5..f2ea73f 100644
+--- a/src/backends/input/input_common.h
++++ b/src/backends/input/input_common.h
+@@ -28,7 +28,7 @@
+ #define BTN_DOWN 1
+ #define BTN_UP 0
+ 
+-qad_backend_input_t *create_input_backend();
++qad_backend_input_t *create_input_backend(char input_type[]);
+ 
+ // int move(int x, int y, int event);
+ 
+-- 
+2.41.0
+
diff --git a/meta-oe/recipes-extended/qad/qad_git.bb b/meta-oe/recipes-extended/qad/qad_git.bb
index e2a59139d9..056f28a0a4 100644
--- a/meta-oe/recipes-extended/qad/qad_git.bb
+++ b/meta-oe/recipes-extended/qad/qad_git.bb
@@ -9,7 +9,8 @@  LICENSE = "MIT & GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=402cce7fbcb6ea9ab5a0378dd7f40806 \
                     file://openqa/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                    "
-SRC_URI = "git://gitlab.com/CodethinkLabs/qad/qad;branch=main;protocol=https"
+SRC_URI = "git://gitlab.com/CodethinkLabs/qad/qad;branch=main;protocol=https \
+           file://0001-Fix-warnings-found-by-clang-compiler.patch"
 
 SRCREV = "ae0c099c1fdc0ca6f5d631cea6b302937122b362"