diff mbox series

[3/4] systemd-boot: use MESON_TARGET

Message ID 20230809144917.3110384-3-ross.burton@arm.com
State New
Headers show
Series [1/4] meson.bbclass: add MESON_TARGET | expand

Commit Message

Ross Burton Aug. 9, 2023, 2:49 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

Instead of re-implementing do_compile, use MESON_TARGET.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-core/systemd/systemd-boot_254.bb | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd-boot_254.bb b/meta/recipes-core/systemd/systemd-boot_254.bb
index e887e636e86..a490c0328e6 100644
--- a/meta/recipes-core/systemd/systemd-boot_254.bb
+++ b/meta/recipes-core/systemd/systemd-boot_254.bb
@@ -22,6 +22,8 @@  c_ld = ${@meson_array('EFI_LD', d)}
 EOF
 }
 
+MESON_TARGET = "systemd-boot"
+
 EXTRA_OEMESON += "-Defi=true \
                   -Dbootloader=true \
                   -Dman=false \
@@ -51,10 +53,6 @@  TUNE_CCARGS:remove = "-mfpmath=sse"
 COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
 COMPATIBLE_HOST:x86-x32 = "null"
 
-do_compile() {
-	ninja systemd-boot
-}
-
 do_install() {
 	install -d ${D}${EFI_FILES_PATH}
 	install ${B}/src/boot/efi/systemd-boot*.efi ${D}${EFI_FILES_PATH}/${SYSTEMD_BOOT_IMAGE}