diff mbox series

musl: Upgrade to tip of trunk

Message ID 20230802034127.3511206-1-raj.khem@gmail.com
State Accepted, archived
Commit e3c2bc571e173e230cd3942888bdcf6423f14a2e
Headers show
Series musl: Upgrade to tip of trunk | expand

Commit Message

Khem Raj Aug. 2, 2023, 3:41 a.m. UTC
Brings following changes

* 83b858f8 fix rejection of dns responses with pointers past 512 byte offset
* a4ecaf89 dns stub resolver: increase buffer size to handle chained CNAMEs
* 40834f6c printf core: fix gratuitous integer formatting buffer size
* 3a23cd06 all printf variants: fix argument type handling for %c and %lc
* fa4a8abd fix public clone function to be safe and usable by applications
* 0c277ff1 fix broken thread list unlocking after fork
* 4653b987 mbrtowc: Fix wrong return value when n > UINT_MAX
* b90841e2 configure: replace -Os with equivalent based on -O2

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/musl/musl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index b4c2b1f8980..0e87a6b49eb 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "718f363bc2067b6487900eddc9180c84e7739f80"
+SRCREV = "83b858f83b658bd34eca5d8ad4d145f673ae7e5e"
 
 BASEVER = "1.2.4"