diff mbox series

[meta-arago,kirkstone/master,4/5] packagegroup-arago-boot: add a new group for all-around useful packages

Message ID 20230728002032.853330-5-rs@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series Packagegroup cleaning and a new proposal | expand

Commit Message

Randolph Sapp July 28, 2023, 12:20 a.m. UTC
From: Randolph Sapp <rs@ti.com>

Add a new package group for performance or QoL tools that all images
should inherit and add the first example of a package that should belong
here.

Irqbalance is a good example. It helps reduce irq response delays on
most if not all of our platforms and is only problematic for users
attempting to reduce jitter specifically through the use of irq pinning,
in which case it can be easily disabled.

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 .../recipes-core/images/arago-image.inc         |  1 +
 .../packagegroups/packagegroup-arago-boot.bb    | 17 +++++++++++++++++
 .../packagegroup-arago-tisdk-addons.bb          |  1 -
 3 files changed, 18 insertions(+), 1 deletion(-)
 create mode 100644 meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-boot.bb

Comments

Denys Dmytriyenko July 28, 2023, 9:09 p.m. UTC | #1
"boot" packagegroup is usually used to list mandatory components required to 
boot the target.

"base" is where you list a minimal set of additional components that are often 
useful, but the target can still boot without.

And one can argue that performance util like irqbalance doesn't fit either of 
the above. While is probably fine to be included in all default images except 
tiny. Come to think of it, "addons" was a perfect place for it...


On Thu, Jul 27, 2023 at 07:20:31PM -0500, Randolph Sapp via lists.yoctoproject.org wrote:
> From: Randolph Sapp <rs@ti.com>
> 
> Add a new package group for performance or QoL tools that all images
> should inherit and add the first example of a package that should belong
> here.
> 
> Irqbalance is a good example. It helps reduce irq response delays on
> most if not all of our platforms and is only problematic for users
> attempting to reduce jitter specifically through the use of irq pinning,
> in which case it can be easily disabled.
> 
> Signed-off-by: Randolph Sapp <rs@ti.com>
> ---
>  .../recipes-core/images/arago-image.inc         |  1 +
>  .../packagegroups/packagegroup-arago-boot.bb    | 17 +++++++++++++++++
>  .../packagegroup-arago-tisdk-addons.bb          |  1 -
>  3 files changed, 18 insertions(+), 1 deletion(-)
>  create mode 100644 meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-boot.bb
> 
> diff --git a/meta-arago-distro/recipes-core/images/arago-image.inc b/meta-arago-distro/recipes-core/images/arago-image.inc
> index d00c1f70..0421dca3 100644
> --- a/meta-arago-distro/recipes-core/images/arago-image.inc
> +++ b/meta-arago-distro/recipes-core/images/arago-image.inc
> @@ -11,6 +11,7 @@ EXTRA_IMAGECMD:ext2.gz += "-i 4096"
>  
>  IMAGE_INSTALL = " \
>  	packagegroup-core-boot \
> +	packagegroup-arago-boot \
>  	${VIRTUAL-RUNTIME_initramfs} \
>  	${CORE_IMAGE_EXTRA_INSTALL} \
>  "
> diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-boot.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-boot.bb
> new file mode 100644
> index 00000000..c9b87a45
> --- /dev/null
> +++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-boot.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Tools or utilities that all images should inherit"
> +DESCRIPTION = "These are packages that lead to general performance or QoL improvements on our platforms that should be inherited by all images. The idea is to keep this group as small as possible moving forward for compatibility with things like the tisdk-tiny-image build target."
> +LICENSE = "MIT"
> +PR = "r0"
> +
> +PACKAGE_ARCH = "${MACHINE_ARCH}"
> +
> +inherit packagegroup
> +
> +# packages that lead to general performance improvements
> +PERFORMANCE_UTILS = " \
> +    irqbalance \
> +"
> +
> +RDEPENDS:${PN} = "\
> +    ${PERFORMANCE_UTILS} \
> +"
> diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
> index c678460d..a9b71fd1 100644
> --- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
> +++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
> @@ -50,7 +50,6 @@ UTILS:append:omap-a15 = " mmc-utils \
>  
>  UTILS:append:k3 = " mmc-utils \
>                      switch-config \
> -                    irqbalance \
>                      ti-rpmsg-char \
>                      ti-rpmsg-char-examples \
>                      statcol \
> -- 
> 2.41.0
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/arago-image.inc b/meta-arago-distro/recipes-core/images/arago-image.inc
index d00c1f70..0421dca3 100644
--- a/meta-arago-distro/recipes-core/images/arago-image.inc
+++ b/meta-arago-distro/recipes-core/images/arago-image.inc
@@ -11,6 +11,7 @@  EXTRA_IMAGECMD:ext2.gz += "-i 4096"
 
 IMAGE_INSTALL = " \
 	packagegroup-core-boot \
+	packagegroup-arago-boot \
 	${VIRTUAL-RUNTIME_initramfs} \
 	${CORE_IMAGE_EXTRA_INSTALL} \
 "
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-boot.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-boot.bb
new file mode 100644
index 00000000..c9b87a45
--- /dev/null
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-boot.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Tools or utilities that all images should inherit"
+DESCRIPTION = "These are packages that lead to general performance or QoL improvements on our platforms that should be inherited by all images. The idea is to keep this group as small as possible moving forward for compatibility with things like the tisdk-tiny-image build target."
+LICENSE = "MIT"
+PR = "r0"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+# packages that lead to general performance improvements
+PERFORMANCE_UTILS = " \
+    irqbalance \
+"
+
+RDEPENDS:${PN} = "\
+    ${PERFORMANCE_UTILS} \
+"
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
index c678460d..a9b71fd1 100644
--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
@@ -50,7 +50,6 @@  UTILS:append:omap-a15 = " mmc-utils \
 
 UTILS:append:k3 = " mmc-utils \
                     switch-config \
-                    irqbalance \
                     ti-rpmsg-char \
                     ti-rpmsg-char-examples \
                     statcol \