diff mbox series

[meta-python,5/9] python3-blinker: upgrade 1.5 -> 1.6.2

Message ID 20230721192530.2515633-5-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/9] python3-awesomeversion: upgrade 22.9.0 -> 23.5.0 | expand

Commit Message

Trevor Gamblin July 21, 2023, 7:25 p.m. UTC
blinker now needs setuptools.build_meta instead of setuptools3.

Changelog (https://github.com/pallets-eco/blinker/blob/main/CHANGES.rst):

Version 1.6.2
Released 2023-04-12

- Type annotations are not evaluated at runtime. typing-extensions is not a runtime dependency. :pr:`94`

Version 1.6.1
Released 2023-04-09

- Ensure that py.typed is present in the distributions (to enable other projects to use blinker's typing).
- Require typing-extensions > 4.2 to ensure it includes ParamSpec. :issue:`90`

Version 1.6
Released 2023-04-02

- Add a muted context manager to temporarily turn off a signal. :pr:`84`
- Allow int senders (alongside existing string senders). :pr:`83`
- Add a send_async method to the Signal to allow signals to send to coroutine receivers. :pr:`76`
- Update and modernise the project structure to match that used by the pallets projects. :pr:`77`
- Add an intial set of type hints for the project.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../{python3-blinker_1.5.bb => python3-blinker_1.6.2.bb}      | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-blinker_1.5.bb => python3-blinker_1.6.2.bb} (72%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-blinker_1.5.bb b/meta-python/recipes-devtools/python/python3-blinker_1.6.2.bb
similarity index 72%
rename from meta-python/recipes-devtools/python/python3-blinker_1.5.bb
rename to meta-python/recipes-devtools/python/python3-blinker_1.6.2.bb
index dae1e39437..8e77df088d 100644
--- a/meta-python/recipes-devtools/python/python3-blinker_1.5.bb
+++ b/meta-python/recipes-devtools/python/python3-blinker_1.6.2.bb
@@ -2,9 +2,9 @@  DESCRIPTION = "Fast, simple object-to-object and broadcast signaling."
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=42cd19c88fc13d1307a4efd64ee90e4e"
 
-SRC_URI[sha256sum] = "923e5e2f69c155f2cc42dafbbd70e16e3fde24d2d4aa2ab72fbe386238892462"
+SRC_URI[sha256sum] = "4afd3de66ef3a9f8067559fb7a1cbe555c17dcbe15971b05d1b625c3e7abe213"
 
-inherit pypi setuptools3 ptest
+inherit pypi python_setuptools_build_meta ptest
 
 SRC_URI += "file://run-ptest"