diff mbox series

[RFC,2/4] devtools: protobuf: add utf8-range recipe

Message ID 20230720162535.116519-3-peron.clem@gmail.com
State New
Headers show
Series Bump Protobuf/gRPC | expand

Commit Message

Clément Péron July 20, 2023, 4:23 p.m. UTC
Utf8 range is a new algorithm that implement fast UTF8 validation.

It is required to compile examples for new protobuf.

Signed-off-by: Clément Péron <peron.clem@gmail.com>
---
 .../protobuf/utf8-range_git.bb                | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/protobuf/utf8-range_git.bb
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/protobuf/utf8-range_git.bb b/meta-oe/recipes-devtools/protobuf/utf8-range_git.bb
new file mode 100644
index 000000000..86ecb74d6
--- /dev/null
+++ b/meta-oe/recipes-devtools/protobuf/utf8-range_git.bb
@@ -0,0 +1,22 @@ 
+SUMMARY = "Fast UTF-8 validation with Range algorithm"
+DESCRIPTION = "This is a brand new algorithm to leverage SIMD for fast UTF-8 \
+string validation. Both NEON(armv8a) and SSE4 versions are implemented."
+HOMEPAGE = "https://github.com/protocolbuffers/utf8_range"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d4974d297231477b2ff507c35d61c13c"
+
+DEPENDS = "abseil-cpp"
+
+SRC_URI = "git://github.com/protocolbuffers/utf8_range.git;branch=main;protocol=https"
+SRCREV = "d863bc33e15cba6d873c878dcca9e6fe52b2f8cb"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "\
+    -Dutf8_range_ENABLE_TESTS=OFF \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+