ruby: do not parallel install

Message ID 20220121134707.1894999-1-alex@linutronix.de
State Accepted, archived
Commit 1dc5cdf683133d210658eba9a619b737ec95cfe3
Headers show
Series ruby: do not parallel install | expand

Commit Message

Alexander Kanavin Jan. 21, 2022, 1:47 p.m. UTC
ruby's makefiles are rebuilding several items on every invocation,
even if nothing changed, all of which are factored into libruby.so
and cause it to be relinked as well. This does not seem to affect plain
make invocation, but does cause races in make install:

https://bugzilla.yoctoproject.org/show_bug.cgi?id=14695

Rather than figure out how to use make properly and convince upstream
of it, let's just do serial installs and file a bug:

https://bugs.ruby-lang.org/issues/18506

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-devtools/ruby/ruby_3.1.0.bb | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Patch

diff --git a/meta/recipes-devtools/ruby/ruby_3.1.0.bb b/meta/recipes-devtools/ruby/ruby_3.1.0.bb
index 7183c93d45..e250164d2c 100644
--- a/meta/recipes-devtools/ruby/ruby_3.1.0.bb
+++ b/meta/recipes-devtools/ruby/ruby_3.1.0.bb
@@ -48,9 +48,7 @@  EXTRA_OECONF:append:libc-musl:riscv32 = "\
     --with-coroutine=copy \
 "
 
-do_install() {
-    oe_runmake 'DESTDIR=${D}' install
-}
+PARALLEL_MAKEINST = ""
 
 do_install:append:class-target () {
     # Find out rbconfig.rb from .installed.list