[3/3] arm/u-boot: add patch to support higher DRAM on TC

Message ID 20220121115643.485616-3-arunachalam.ganapathy@arm.com
State New
Headers show
Series [1/3] arm-bsp/optee: add patch to support higher DRAM on TC | expand

Commit Message

Arunachalam Ganapathy Jan. 21, 2022, 11:56 a.m. UTC
Signed-off-by: Arunachalam Ganapathy <arunachalam.ganapathy@arm.com>
Change-Id: Ifbf9e73a0e1134d1a0ecce036c9ba53fe7d5b1bf
---
 ...m-total_compute-increase-DRAM-to-8GB.patch | 47 +++++++++++++++++++
 .../recipes-bsp/u-boot/u-boot_%.bbappend      |  5 +-
 2 files changed, 51 insertions(+), 1 deletion(-)
 create mode 100644 meta-arm-bsp/recipes-bsp/u-boot/u-boot/tc/0001-arm-total_compute-increase-DRAM-to-8GB.patch

Patch

diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot/tc/0001-arm-total_compute-increase-DRAM-to-8GB.patch b/meta-arm-bsp/recipes-bsp/u-boot/u-boot/tc/0001-arm-total_compute-increase-DRAM-to-8GB.patch
new file mode 100644
index 0000000..d1cfcdb
--- /dev/null
+++ b/meta-arm-bsp/recipes-bsp/u-boot/u-boot/tc/0001-arm-total_compute-increase-DRAM-to-8GB.patch
@@ -0,0 +1,47 @@ 
+From bdb7de7cdef6ece51dfcee927d3ce0c97fc431f0 Mon Sep 17 00:00:00 2001
+From: Usama Arif <usama.arif@arm.com>
+Date: Tue, 12 Oct 2021 13:43:16 +0100
+Subject: [PATCH] arm: total_compute: increase DRAM to 8GB
+
+The extra 6GB start at 0x8080000000.
+
+Signed-off-by: Usama Arif <usama.arif@arm.com>
+
+Upstream-Status: Backport [https://github.com/u-boot/u-boot/commit/b20b16a794b073807ef8d6840772a92788b3e226]
+Signed-off-by: Arunachalam Ganapathy <arunachalam.ganapathy@arm.com>
+---
+ board/armltd/total_compute/total_compute.c | 3 +++
+ include/configs/total_compute.h            | 3 +++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/board/armltd/total_compute/total_compute.c b/board/armltd/total_compute/total_compute.c
+index b7eaab0851..b7772f79a3 100644
+--- a/board/armltd/total_compute/total_compute.c
++++ b/board/armltd/total_compute/total_compute.c
+@@ -59,6 +59,9 @@ int dram_init_banksize(void)
+ 	gd->bd->bi_dram[0].start = PHYS_SDRAM_1;
+ 	gd->bd->bi_dram[0].size = PHYS_SDRAM_1_SIZE;
+ 
++	gd->bd->bi_dram[1].start = PHYS_SDRAM_2;
++	gd->bd->bi_dram[1].size = PHYS_SDRAM_2_SIZE;
++
+ 	return 0;
+ }
+ 
+diff --git a/include/configs/total_compute.h b/include/configs/total_compute.h
+index cc93f1930a..283268607a 100644
+--- a/include/configs/total_compute.h
++++ b/include/configs/total_compute.h
+@@ -34,6 +34,9 @@
+ #define PHYS_SDRAM_1_SIZE	0x80000000 - DRAM_SEC_SIZE
+ #define CONFIG_SYS_SDRAM_BASE	PHYS_SDRAM_1
+ 
++#define PHYS_SDRAM_2		0x8080000000
++#define PHYS_SDRAM_2_SIZE	0x180000000
++
+ #define CONFIG_ARM_PL180_MMCI_BASE		0x001c050000
+ #define CONFIG_SYS_MMC_MAX_BLK_COUNT		127
+ #define CONFIG_ARM_PL180_MMCI_CLOCK_FREQ	12000000
+-- 
+2.30.2
+
diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
index 5a927ba..a0709dd 100644
--- a/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -77,4 +77,7 @@  SRC_URI:append:fvp-base-arm32 = " file://0001-Add-vexpress_aemv8a_aarch32-varian
 #
 # TC0 and TC1 MACHINES
 #
-SRC_URI:append:tc = " file://bootargs.cfg"
+SRC_URI:append:tc = " \
+        file://bootargs.cfg \
+        file://0001-arm-total_compute-increase-DRAM-to-8GB.patch \
+        "