diff mbox series

[AUH] python3-click: upgrading to 8.1.4 SUCCEEDED

Message ID 20230712053020.67A49EB64D9@smtp.lore.kernel.org
State New
Headers show
Series [AUH] python3-click: upgrading to 8.1.4 SUCCEEDED | expand

Commit Message

auh@moto-timo.dev July 12, 2023, 5:30 a.m. UTC
Hello,

this email is a notification from the Auto Upgrade Helper
that the automatic attempt to upgrade the recipe *python3-click* to *8.1.4* has Succeeded.

Next steps:
    - apply the patch: git am 0001-python3-click-upgrade-8.1.3-8.1.4.patch
    - check the changes to upstream patches and summarize them in the commit message,
    - compile an image that contains the package
    - perform some basic sanity tests
    - amend the patch and sign it off: git commit -s --reset-author --amend
    - send it to the appropriate mailing list

Alternatively, if you believe the recipe should not be upgraded at this time,
you can fill RECIPE_NO_UPDATE_REASON in respective recipe file so that
automatic upgrades would no longer be attempted.

Please review the attached files for further information and build/update failures.
Any problem please file a bug at https://bugzilla.yoctoproject.org/enter_bug.cgi?product=Automated%20Update%20Handler

Regards,
The Upgrade Helper

-- >8 --
From 755268190c412d7326cb048f455123572ed6ded1 Mon Sep 17 00:00:00 2001
From: Upgrade Helper <auh@moto-timo.dev>
Date: Tue, 11 Jul 2023 17:46:24 -0500
Subject: [PATCH] python3-click: upgrade 8.1.3 -> 8.1.4

---
 .../0001-tests-Fix-test_bytes_args.patch      | 41 -------------------
 ...-click_8.1.3.bb => python3-click_8.1.4.bb} |  7 +---
 2 files changed, 2 insertions(+), 46 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-click/0001-tests-Fix-test_bytes_args.patch
 rename meta-python/recipes-devtools/python/{python3-click_8.1.3.bb => python3-click_8.1.4.bb} (85%)
diff mbox series

Patch

From 755268190c412d7326cb048f455123572ed6ded1 Mon Sep 17 00:00:00 2001
From: Upgrade Helper <auh@moto-timo.dev>
Date: Tue, 11 Jul 2023 17:46:24 -0500
Subject: [PATCH] python3-click: upgrade 8.1.3 -> 8.1.4

---
 .../0001-tests-Fix-test_bytes_args.patch      | 41 -------------------
 ...-click_8.1.3.bb => python3-click_8.1.4.bb} |  7 +---
 2 files changed, 2 insertions(+), 46 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-click/0001-tests-Fix-test_bytes_args.patch
 rename meta-python/recipes-devtools/python/{python3-click_8.1.3.bb => python3-click_8.1.4.bb} (85%)

diff --git a/meta-python/recipes-devtools/python/python3-click/0001-tests-Fix-test_bytes_args.patch b/meta-python/recipes-devtools/python/python3-click/0001-tests-Fix-test_bytes_args.patch
deleted file mode 100644
index e69a37c40..000000000
--- a/meta-python/recipes-devtools/python/python3-click/0001-tests-Fix-test_bytes_args.patch
+++ /dev/null
@@ -1,41 +0,0 @@ 
-From da83bd7ca0959027086115f23534957b0917aaa5 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 27 Apr 2023 22:21:24 -0700
-Subject: [PATCH] tests: Fix test_bytes_args
-
-sys.stdin.encoding is readonly therefore use Mocking to wrap it.
-Sourced from - Alpine
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- tests/test_arguments.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test_arguments.py b/tests/test_arguments.py
-index 735df4b..3395c55 100644
---- a/tests/test_arguments.py
-+++ b/tests/test_arguments.py
-@@ -1,4 +1,5 @@
- import sys
-+from unittest import mock
- 
- import pytest
- 
-@@ -86,9 +87,12 @@ def test_bytes_args(runner, monkeypatch):
-         ), "UTF-8 encoded argument should be implicitly converted to Unicode"
- 
-     # Simulate empty locale environment variables
--    monkeypatch.setattr(sys.stdin, "encoding", "utf-8")
-     monkeypatch.setattr(sys, "getfilesystemencoding", lambda: "utf-8")
-     monkeypatch.setattr(sys, "getdefaultencoding", lambda: "utf-8")
-+    # sys.stdin.encoding is readonly, needs some extra effort to patch.
-+    stdin = mock.Mock(wraps=sys.stdin)
-+    stdin.encoding = "utf-8"
-+    monkeypatch.setattr(sys, "stdin", stdin)
- 
-     runner.invoke(
-         from_bytes,
--- 
-2.40.1
-
diff --git a/meta-python/recipes-devtools/python/python3-click_8.1.3.bb b/meta-python/recipes-devtools/python/python3-click_8.1.4.bb
similarity index 85%
rename from meta-python/recipes-devtools/python/python3-click_8.1.3.bb
rename to meta-python/recipes-devtools/python/python3-click_8.1.4.bb
index 9b8ea94c2..dc624c43d 100644
--- a/meta-python/recipes-devtools/python/python3-click_8.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-click_8.1.4.bb
@@ -8,14 +8,11 @@  HOMEPAGE = "http://click.pocoo.org/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
 
-SRC_URI[sha256sum] = "7682dc8afb30297001674575ea00d1814d808d6a36af415a82bd481d37ba7b8e"
+SRC_URI[sha256sum] = "b97d0c74955da062a7d4ef92fadb583806a585b2ea81958a81bd72726cbb8e37"
 
 inherit pypi setuptools3 ptest
 
-SRC_URI += " \
-	file://0001-tests-Fix-test_bytes_args.patch \
-	file://run-ptest \
-"
+SRC_URI += "file://run-ptest"
 
 RDEPENDS:${PN}-ptest += " \
 	${PYTHON_PN}-pytest \
-- 
2.25.1