diff mbox series

[1/3] python3-pylibfdt: add recipe

Message ID 20230711011104.2807078-1-tgamblin@baylibre.com
State New
Headers show
Series [1/3] python3-pylibfdt: add recipe | expand

Commit Message

Trevor Gamblin July 11, 2023, 1:11 a.m. UTC
This is required by python3-dtschema (already in oe-core) and
likely some other modules, so add the recipe.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/python3-pylibfdt_1.6.1.bb             | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb

Comments

Bruce Ashfield July 11, 2023, 1:26 a.m. UTC | #1
On Mon, Jul 10, 2023 at 9:11 PM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>
> This is required by python3-dtschema (already in oe-core) and
> likely some other modules, so add the recipe.

We are now on the 3rd (or 4th) iteration of attempts to add this.

Rather than re-hashing the discussion, I suggest searching the mailing
list for libfdt.

The summary is:  the pypi version is not up to date, and this python
library should be built out of the dtc repository and provided that
way.

Bruce

>
> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ---
>  .../python/python3-pylibfdt_1.6.1.bb             | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>  create mode 100644 meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
>
> diff --git a/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
> new file mode 100644
> index 0000000000..9dd01a1449
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
> @@ -0,0 +1,16 @@
> +SUMMARY = "Python binding for libfdt"
> +HOMEPAGE = "https://pypi.org/project/pylibfdt/"
> +LICENSE = "BSD-2-Clause & GPL-2.0-or-later"
> +LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> +                    file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927"
> +
> +inherit pypi python_setuptools_build_meta
> +
> +PYPI_PACKAGE = "pylibfdt"
> +
> +SRC_URI[sha256sum] = "90c667c5adf44c6ab2f13bdc566598897784c7b781bed91064e7373bd270b778"
> +
> +BBCLASSEXTEND = "native nativesdk"
> +
> +DEPENDS += "python3-setuptools-scm-native swig-native"
> +
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#184109): https://lists.openembedded.org/g/openembedded-core/message/184109
> Mute This Topic: https://lists.openembedded.org/mt/100070604/1050810
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [bruce.ashfield@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Trevor Gamblin July 11, 2023, 6:24 p.m. UTC | #2
On 2023-07-10 21:26, Bruce Ashfield wrote:
> On Mon, Jul 10, 2023 at 9:11 PM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>> This is required by python3-dtschema (already in oe-core) and
>> likely some other modules, so add the recipe.
> We are now on the 3rd (or 4th) iteration of attempts to add this.
>
> Rather than re-hashing the discussion, I suggest searching the mailing
> list for libfdt.
>
> The summary is:  the pypi version is not up to date, and this python
> library should be built out of the dtc repository and provided that
> way.

Thanks for the heads-up, I hadn't seen the others. I noticed that you 
have python3-dtc in meta-virtualization and that seems to cover 
python3-dtschema's needs. Will it be an issue for meta-virt if I move 
that to oe-core?

Trevor

>
> Bruce
>
>> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>> ---
>>   .../python/python3-pylibfdt_1.6.1.bb             | 16 ++++++++++++++++
>>   1 file changed, 16 insertions(+)
>>   create mode 100644 meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
>>
>> diff --git a/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
>> new file mode 100644
>> index 0000000000..9dd01a1449
>> --- /dev/null
>> +++ b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
>> @@ -0,0 +1,16 @@
>> +SUMMARY = "Python binding for libfdt"
>> +HOMEPAGE = "https://pypi.org/project/pylibfdt/"
>> +LICENSE = "BSD-2-Clause & GPL-2.0-or-later"
>> +LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
>> +                    file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927"
>> +
>> +inherit pypi python_setuptools_build_meta
>> +
>> +PYPI_PACKAGE = "pylibfdt"
>> +
>> +SRC_URI[sha256sum] = "90c667c5adf44c6ab2f13bdc566598897784c7b781bed91064e7373bd270b778"
>> +
>> +BBCLASSEXTEND = "native nativesdk"
>> +
>> +DEPENDS += "python3-setuptools-scm-native swig-native"
>> +
>> --
>> 2.41.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#184109): https://lists.openembedded.org/g/openembedded-core/message/184109
>> Mute This Topic: https://lists.openembedded.org/mt/100070604/1050810
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [bruce.ashfield@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>
Bruce Ashfield July 11, 2023, 7:01 p.m. UTC | #3
On Tue, Jul 11, 2023 at 2:24 PM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>
>
> On 2023-07-10 21:26, Bruce Ashfield wrote:
> > On Mon, Jul 10, 2023 at 9:11 PM Trevor Gamblin <tgamblin@baylibre.com> wrote:
> >> This is required by python3-dtschema (already in oe-core) and
> >> likely some other modules, so add the recipe.
> > We are now on the 3rd (or 4th) iteration of attempts to add this.
> >
> > Rather than re-hashing the discussion, I suggest searching the mailing
> > list for libfdt.
> >
> > The summary is:  the pypi version is not up to date, and this python
> > library should be built out of the dtc repository and provided that
> > way.
>
> Thanks for the heads-up, I hadn't seen the others. I noticed that you
> have python3-dtc in meta-virtualization and that seems to cover
> python3-dtschema's needs. Will it be an issue for meta-virt if I move
> that to oe-core?

That shouldn't be a problem. It is there to support lopper, which we use in Xen
and some other SDK configurations.

I can't recall if there were arch issues, or other gaps in the
support, but that is
something that should pop up quickly.

As for the patch against libfdt in meta-virt, in theory it may not be
required, but
even if it is, I can bbappend it back in the layer.

Bruce

>
> Trevor
>
> >
> > Bruce
> >
> >> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> >> ---
> >>   .../python/python3-pylibfdt_1.6.1.bb             | 16 ++++++++++++++++
> >>   1 file changed, 16 insertions(+)
> >>   create mode 100644 meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
> >>
> >> diff --git a/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
> >> new file mode 100644
> >> index 0000000000..9dd01a1449
> >> --- /dev/null
> >> +++ b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
> >> @@ -0,0 +1,16 @@
> >> +SUMMARY = "Python binding for libfdt"
> >> +HOMEPAGE = "https://pypi.org/project/pylibfdt/"
> >> +LICENSE = "BSD-2-Clause & GPL-2.0-or-later"
> >> +LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> >> +                    file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927"
> >> +
> >> +inherit pypi python_setuptools_build_meta
> >> +
> >> +PYPI_PACKAGE = "pylibfdt"
> >> +
> >> +SRC_URI[sha256sum] = "90c667c5adf44c6ab2f13bdc566598897784c7b781bed91064e7373bd270b778"
> >> +
> >> +BBCLASSEXTEND = "native nativesdk"
> >> +
> >> +DEPENDS += "python3-setuptools-scm-native swig-native"
> >> +
> >> --
> >> 2.41.0
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#184109): https://lists.openembedded.org/g/openembedded-core/message/184109
> >> Mute This Topic: https://lists.openembedded.org/mt/100070604/1050810
> >> Group Owner: openembedded-core+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [bruce.ashfield@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
> >
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
new file mode 100644
index 0000000000..9dd01a1449
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "Python binding for libfdt"
+HOMEPAGE = "https://pypi.org/project/pylibfdt/"
+LICENSE = "BSD-2-Clause & GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+                    file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927"
+
+inherit pypi python_setuptools_build_meta
+
+PYPI_PACKAGE = "pylibfdt"
+
+SRC_URI[sha256sum] = "90c667c5adf44c6ab2f13bdc566598897784c7b781bed91064e7373bd270b778"
+
+BBCLASSEXTEND = "native nativesdk"
+
+DEPENDS += "python3-setuptools-scm-native swig-native"
+