diff mbox series

[meta-oe] flatpak: update dependencies

Message ID 20230710072422.1147397-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-oe] flatpak: update dependencies | expand

Commit Message

Markus Volk July 10, 2023, 7:24 a.m. UTC
- use system bubblewrap and xdg-dbus-proxy instead of building subprojects
- fix seccomp PACKAGECONFIG

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta-oe/recipes-extended/flatpak/flatpak_1.15.4.bb | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/flatpak/flatpak_1.15.4.bb b/meta-oe/recipes-extended/flatpak/flatpak_1.15.4.bb
index fcf80fc854..163d732a86 100644
--- a/meta-oe/recipes-extended/flatpak/flatpak_1.15.4.bb
+++ b/meta-oe/recipes-extended/flatpak/flatpak_1.15.4.bb
@@ -28,11 +28,13 @@  DEPENDS = " \
     json-glib \
     libarchive \
     libcap \
+    libxml2 \
     libxslt-native \
     ostree \
     polkit \
     python3-pyparsing-native \
     xmlto-native \
+    zstd \
 "
 
 RDEPENDS:${PN} = " \
@@ -40,17 +42,20 @@  RDEPENDS:${PN} = " \
     ca-certificates \
     dconf \
     flatpak-xdg-utils \
+    xdg-dbus-proxy \
 "
 
+EXTRA_OEMESON += "-Dsystem_dbus_proxy=${bindir}/xdg-dbus-proxy -Dsystem_bubblewrap=${bindir}/bwrap"
+
 GIR_MESON_OPTION = ""
 
-PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,xauth"
+PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,xauth socat-native"
 PACKAGECONFIG[xauth] = "-Dxauth=enabled,-Dxauth=disabled,xauth"
 PACKAGECONFIG[seccomp] = "-Dseccomp=enabled,-Dseccomp=disabled,libseccomp"
 
 PACKAGECONFIG ?= " \
     ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xauth', '', d)} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'security', 'seccomp', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'seccomp', 'seccomp', '', d)} \
 "
 
 FILES:${PN} += "${libdir} ${datadir}"