diff mbox series

[meta-python] python3-redis: upgrade 4.5.5 -> 4.6.0

Message ID 1688699627-2519-19-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-redis: upgrade 4.5.5 -> 4.6.0 | expand

Commit Message

Mingyu Wang (Fujitsu) July 7, 2023, 3:13 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
Experimental Features
-----------------------
 Support JSON.MERGE command (#2761)
 Support JSON.MSET command (#2766)

New Features
-------------
 Extract abstract async connection class (#2734)
 Add support for WAITAOF (#2760)
 Introduce OutOfMemoryError exception for Redis write command rejections due to OOM errors (#2778)
 Add WITHSCORE argument to ZRANK (#2758)
 Add support for sharded pubsub in sync client (#2762)

Bug Fixes
-----------
 Fix dead weakref in sentinel connection causing ReferenceError (#2767) (#2771)
 Fix Key Error in parse_xinfo_stream (#2788)
 Remove unnecessary __del__ handlers (#2755)
 Added support for missing argument to SentinelManagedConnection.read_response() (#2756)
 Fixed resp3 dict parse response (#2757)

Maintenance
-------------
 Fix type hint for retry_on_error in async cluster (#2804)
 Clean up documents and fix some redirects (#2801)
 Add unit tests for the connect method of all Redis connection classes (#2631)
 Docstring formatting fix (#2796)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-redis_4.5.5.bb => python3-redis_4.6.0.bb}   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-redis_4.5.5.bb => python3-redis_4.6.0.bb} (83%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-redis_4.5.5.bb b/meta-python/recipes-devtools/python/python3-redis_4.6.0.bb
similarity index 83%
rename from meta-python/recipes-devtools/python/python3-redis_4.5.5.bb
rename to meta-python/recipes-devtools/python/python3-redis_4.6.0.bb
index eb407a2a15..47eb7c2096 100644
--- a/meta-python/recipes-devtools/python/python3-redis_4.5.5.bb
+++ b/meta-python/recipes-devtools/python/python3-redis_4.6.0.bb
@@ -4,7 +4,7 @@  HOMEPAGE = "http://github.com/andymccurdy/redis-py"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=1db1f331d351900707368237cc4880cf"
 
-SRC_URI[sha256sum] = "dc87a0bdef6c8bfe1ef1e1c40be7034390c2ae02d92dcd0c7ca1729443899880"
+SRC_URI[sha256sum] = "585dc516b9eb042a619ef0a39c3d7d55fe81bdb4df09a52c9cdde0d07bf1aa7d"
 
 inherit pypi setuptools3